Bug 63178

Summary: REGRESSION (r89449): http/tests/inspector/extensions-resources-redirect.html failing on SnowLeopard Intel Release (Tests), Windows 7 Release (Tests), Qt
Product: WebKit Reporter: Jessie Berlin <jberlin>
Component: Web Inspector (Deprecated)Assignee: Vsevolod Vlasov <vsevik>
Status: RESOLVED FIXED    
Severity: Normal CC: aroben, caseq, jberlin, ossy, pfeldman, vsevik
Priority: P2 Keywords: InRadar, LayoutTestFailure, Regression
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
URL: http://build.webkit.org/results/SnowLeopard Intel Release (Tests)/r89449 (30638)/results.html
Attachments:
Description Flags
Patch pfeldman: review+

Comment 1 Jessie Berlin 2011-06-22 13:59:08 PDT
Added expected failing results http://trac.webkit.org/changeset/89477
Comment 2 Jessie Berlin 2011-06-22 13:59:28 PDT
<rdar://problem/9658001>
Comment 3 Csaba Osztrogon√°c 2011-06-23 08:01:05 PDT
I skipped it on Qt: http://trac.webkit.org/changeset/89570

But I don't think if it is a good idea to check in expected fails and/or skipping a failing test because of a regression. Regressions shouldn't be in trunk.
Comment 4 Vsevolod Vlasov 2011-06-23 08:10:05 PDT
this is a problem in test, not in the code, I have a patch ready and will upload it tomorrow.
Comment 5 Vsevolod Vlasov 2011-06-24 07:50:19 PDT
Created attachment 98492 [details]
Patch
Comment 6 Adam Roben (:aroben) 2011-06-24 08:53:03 PDT
I wonder if this fill fix bug 63325 and/or bug 57491?
Comment 7 Vsevolod Vlasov 2011-06-24 09:04:31 PDT
(In reply to comment #6)
> I wonder if this fill fix bug 63325 and/or bug 57491?

I don't think so.
I was not aware of these bugs, and could have a deeper look on them, but they are most probably related to the test implementation details, that were present in it initially, while this patch only fixes the problem caused by recent changes in a way inspector receives resources content.
Comment 8 Jessie Berlin 2011-06-24 09:43:34 PDT
Comment on attachment 98492 [details]
Patch

Unofficial r=me (I am not a reviewer yet)
Comment 9 Pavel Feldman 2011-06-27 11:38:36 PDT
Comment on attachment 98492 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=98492&action=review

> LayoutTests/platform/mac/http/tests/inspector/extensions-resources-redirect-expected.txt:-1
> -Tests WebInspector extension API

Are you expecting this blank output on a Mac?
Comment 10 Pavel Feldman 2011-06-27 11:40:12 PDT
Comment on attachment 98492 [details]
Patch

Ah! you removed the custom expectation!
Comment 11 Andrey Kosyakov 2011-06-28 08:28:39 PDT
Manually committed r89931: http://trac.webkit.org/changeset/89931