Bug 62509

Summary: Factor IconController out of FrameLoader
Product: WebKit Reporter: Adam Barth <abarth>
Component: New BugsAssignee: Adam Barth <abarth>
Status: RESOLVED FIXED    
Severity: Normal CC: cmarcelo, darin, eric, japhet
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 29947    
Attachments:
Description Flags
Patch
none
Patch japhet: review+, abarth: commit-queue-

Description Adam Barth 2011-06-12 02:34:41 PDT
Factor IconController out of FrameLoader
Comment 1 Adam Barth 2011-06-12 02:38:51 PDT
Created attachment 96873 [details]
Patch
Comment 2 WebKit Review Bot 2011-06-12 03:52:47 PDT
Comment on attachment 96873 [details]
Patch

Attachment 96873 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/8826893
Comment 3 Adam Barth 2011-06-12 04:11:26 PDT
Created attachment 96877 [details]
Patch
Comment 4 Nate Chapin 2011-06-13 11:39:04 PDT
Comment on attachment 96877 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=96877&action=review

This is awesome. Just one question :)

> Source/WebCore/loader/icon/IconController.h:51
> +    KURL url();
> +    IconURLs urls(int iconTypes);

Is there anything we can do to make these names more distinct?
Comment 5 Adam Barth 2011-06-13 11:51:08 PDT
(In reply to comment #4)
> (From update of attachment 96877 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=96877&action=review
> 
> This is awesome. Just one question :)
> 
> > Source/WebCore/loader/icon/IconController.h:51
> > +    KURL url();
> > +    IconURLs urls(int iconTypes);
> 
> Is there anything we can do to make these names more distinct?

Sure.  We can rename urls to urlsForTypes.
Comment 6 Adam Barth 2011-06-13 13:36:08 PDT
Committed r88682: <http://trac.webkit.org/changeset/88682>