Bug 61590

Summary: GraphicsLayers for overflow controls on iframe without clipping layer left out of layer tree
Product: WebKit Reporter: James Robinson <jamesr>
Component: New BugsAssignee: James Robinson <jamesr>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, enne, kbr, nduca, simon.fraser, vangelis
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
simon.fraser: review+, commit-queue: commit-queue-
Archive of layout-test-results from cr-jail-7 none

Description James Robinson 2011-05-26 18:56:41 PDT
GraphicsLayers for overflow controls on iframe without clipping layer left out of layer tree
Comment 1 James Robinson 2011-05-26 18:58:56 PDT
Created attachment 95092 [details]
Patch
Comment 2 James Robinson 2011-05-26 19:02:26 PDT
This patch doesn't change the visual appearance of the page (since we don't draw anything for resizers on iframes), but is still important for chromium since without it we can get into a situation where a GraphicsLayer is still alive but suddenly vanishes from the layer tree, which our compositor currently isn't robust to.  I'll try to address that in parallel as well, but IMO this is a cleaner fix to the problems caused by this inconsistency.
Comment 3 WebKit Commit Bot 2011-05-27 03:59:18 PDT
Comment on attachment 95092 [details]
Patch

Rejecting attachment 95092 [details] from commit-queue.

Failed to run "['./Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=cr-jail-7', 'build-..." exit_code: 2

Last 500 characters of output:
tests/xmlhttprequest ................................................................................................................................................................................
http/tests/xmlhttprequest/web-apps ...............
http/tests/xmlhttprequest/workers ...........
http/tests/xmlviewer .
http/tests/xmlviewer/dumpAsText ...........
757.91s total testing time

23656 test cases (99%) succeeded
1 test case (<1%) had incorrect layout
16 test cases (<1%) had stderr output

Full output: http://queues.webkit.org/results/8743232
Comment 4 WebKit Commit Bot 2011-05-27 03:59:22 PDT
Created attachment 95153 [details]
Archive of layout-test-results from cr-jail-7

The attached test failures were seen while running run-webkit-tests on the commit-queue.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.7
Comment 5 James Robinson 2011-05-27 11:20:43 PDT
Whoops, I put chromium-generated results in compositing/iframes/, and that layer tree isn't valid for mac snow leopard, which doesn't have layers for scroll corners.  I'll fix up the expectations before landing.
Comment 6 James Robinson 2011-05-27 13:29:26 PDT
Committed r87547: <http://trac.webkit.org/changeset/87547>