Bug 61574

Summary: Switch MouseRelatedEvent to use IntPoint
Product: WebKit Reporter: Emil A Eklund <eae>
Component: UI EventsAssignee: Emil A Eklund <eae>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, dglazkov, eric, leviw, simon.fraser, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 60318    
Attachments:
Description Flags
Patch
webkit.review.bot: commit-queue-
Patch
none
Patch
none
Patch for landing none

Description Emil A Eklund 2011-05-26 15:57:39 PDT
Convert x,y pairs to IntPoint.
Comment 1 Emil A Eklund 2011-05-31 11:05:28 PDT
Created attachment 95455 [details]
Patch
Comment 2 WebKit Review Bot 2011-05-31 11:19:52 PDT
Comment on attachment 95455 [details]
Patch

Attachment 95455 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/8753418
Comment 3 Emil A Eklund 2011-05-31 13:57:00 PDT
Created attachment 95478 [details]
Patch
Comment 4 Emil A Eklund 2011-05-31 16:25:11 PDT
I guess I'll need to include <wtf/MathExtras.h>.h instead of <math.h> to make the windows build happy.
Comment 5 Emil A Eklund 2011-05-31 16:55:53 PDT
Created attachment 95511 [details]
Patch
Comment 6 Emil A Eklund 2011-05-31 16:57:05 PDT
Hopefully this should make the windows bot happy. Let's wait and see...
Comment 7 Eric Seidel (no email) 2011-05-31 19:28:35 PDT
Comment on attachment 95511 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=95511&action=review

> Source/WebCore/dom/WheelEvent.cpp:46
> +    , m_wheelDelta(IntPoint((int)(wheelTicks.x() * 120), (int)(wheelTicks.y() * 120)))

c++ casts, not c. :)

> Source/WebCore/platform/graphics/IntPoint.h:99
> +        m_x = lroundf((float)m_x * sx);
> +        m_y = lroundf((float)m_y * sy);

Again, c++, not c.  Otherwise fine.
Comment 8 Emil A Eklund 2011-06-01 11:09:03 PDT
Thanks Eric. I'll try to remember to use C++ style casts in the future.
Comment 9 Emil A Eklund 2011-06-01 11:14:14 PDT
Created attachment 95630 [details]
Patch for landing
Comment 10 WebKit Commit Bot 2011-06-01 16:19:14 PDT
Comment on attachment 95630 [details]
Patch for landing

Clearing flags on attachment: 95630

Committed r87865: <http://trac.webkit.org/changeset/87865>
Comment 11 WebKit Commit Bot 2011-06-01 16:19:20 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Emil A Eklund 2011-06-01 16:32:25 PDT
*** Bug 61575 has been marked as a duplicate of this bug. ***