Bug 6150

Summary: safari wrongly retrieves cached link instead of live one
Product: WebKit Reporter: rahul abrol <solushex@gmail.com>
Component: New BugsAssignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED DUPLICATE    
Severity: Major CC: eric@webkit.org
Priority: P2    
Version: 420+   
Hardware: Macintosh   
OS: Mac OS X 10.4   
URL: http://news.bbc.co.uk

Description From 2005-12-19 10:00:29 PST
the video links on the bbc news site all point to a default clip, which the browser should bypass (through 
javascript) to retrieve the main clip for that particular video.  safari succeds at first, but on all subsequent 
attempts it gets stuck with the default clip (reloading the page is required to resolve the issue)...no other 
browser has this problem.

empyting webcore cache repeatedly and/or disabling webcore cache altogether solves the problem, of 
course, there must be a better solution.
------- Comment #1 From 2005-12-21 13:35:30 PST -------
I can't reproduce this, could you describe the steps you take with some more detail? Thanks! 
Kind regards,
Joost de Valk
------- Comment #2 From 2005-12-21 15:49:28 PST -------
There have been various caching bugs throughout the lifetime of WebKit.  Last I heard I think we had them 
all squashed, but it's possible there is still a bug in the cache logic.  If someone is able to reproduce this 
(and better yet find a reduced test case -- which may involve server side logic) we would be *very* 
interested.
------- Comment #3 From 2005-12-21 19:03:03 PST -------
lots of people have reproduced this (i wasn't even the first).  check out this thread for more detail:

http://discussions.apple.com/thread.jspa?messageID=1301296&#1301296

i was using the 12.17.05 build, so unless something was fixed in the past few days the problem is still 
there.  i've also filed this bug with ADC, since i wasn't sure if webkit itself was to blame.
------- Comment #4 From 2005-12-22 01:36:27 PST -------
Thats very helpful, thank you.
------- Comment #5 From 2006-05-22 06:27:58 PST -------
This was reported earlier, but bug 7722 already has a more distinctive title, so closing this one as a duplicate.
------- Comment #6 From 2006-05-22 06:35:23 PST -------

*** This bug has been marked as a duplicate of 7722 ***