Bug 60421

Summary: Custom scrollbars nested inside an overlay scrollbar overflow region end up painting twice
Product: WebKit Reporter: Beth Dakin <bdakin>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bdakin
Priority: P2 Keywords: HasReduction, InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch darin: review+

Description Beth Dakin 2011-05-06 17:36:49 PDT
Right now any overflow region with overlay scrollbars will cause a second pass through the layer tree to paint said scrollbars. Except right now both passes end up painting custom css scrollbars.

Patch forthcoming.

<rdar://problem/9389072>
Comment 1 Beth Dakin 2011-05-06 17:46:23 PDT
Created attachment 92665 [details]
Patch
Comment 2 Beth Dakin 2011-05-06 17:47:16 PDT
This test doesn't do anything right now, but when we have a version of DRT that uses overlay scrollbars, then this test will be valuable.
Comment 3 Darin Adler 2011-05-06 17:47:59 PDT
Comment on attachment 92665 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=92665&action=review

> Source/WebCore/rendering/RenderLayer.cpp:2254
> +    // If this is the special overlay scrollbar painting pass, then don't re-paint any
> +    // non-overlay scrollbars. Only custom-CSS scrollbars will be non-overlay in this
> +    // context.

This comment seems a little long. Maybe you could remove more of what's redundant with the code and concentrate on the why part of this?
Comment 4 Beth Dakin 2011-05-06 17:53:07 PDT
(In reply to comment #3)
> (From update of attachment 92665 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=92665&action=review
> 
> > Source/WebCore/rendering/RenderLayer.cpp:2254
> > +    // If this is the special overlay scrollbar painting pass, then don't re-paint any
> > +    // non-overlay scrollbars. Only custom-CSS scrollbars will be non-overlay in this
> > +    // context.
> 
> This comment seems a little long. Maybe you could remove more of what's redundant with the code and concentrate on the why part of this?

Thanks Darin! I changed it to a better, more-concise comment.

Committed with revision 85990.