Bug 60256

Summary: Web Inspector: rename BrowserDebugger to DOMDebugger
Product: WebKit Reporter: Ilya Tikhonovsky <loislo>
Component: Web Inspector (Deprecated)Assignee: Ilya Tikhonovsky <loislo>
Severity: Normal CC: apavlov, bweinstein, joepeck, keishi, loislo, pfeldman, pmuellr, rik, timothy, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Description Flags
[patch] initial version
[patch] second version yurys: review+

Description Ilya Tikhonovsky 2011-05-05 01:18:14 PDT
The protocol domain name was changed a few days ago.
It'd be nice to change corresponding backend agent name accordingly.
Comment 1 Ilya Tikhonovsky 2011-05-05 02:13:15 PDT
Created attachment 92393 [details]
[patch] initial version
Comment 2 Yury Semikhatsky 2011-05-05 04:01:28 PDT
Comment on attachment 92393 [details]
[patch] initial version

View in context: https://bugs.webkit.org/attachment.cgi?id=92393&action=review

Looks good except that DOMDebuggerAgent variables should become domDebuggerAgent

> Source/WebCore/ChangeLog:9
> +        browserDebugger => DOMDebugger

should be domDebugger, not DOMDebugger

> Source/WebCore/inspector/CodeGeneratorInspector.pm:41
> +    "domainAccessor" => "m_DOMDebuggerAgent",


> Source/WebCore/inspector/InspectorAgent.h:136
> +    InspectorDOMDebuggerAgent* DOMDebuggerAgent() const { return m_DOMDebuggerAgent.get(); }

domDebuggerAgent (see domStorageAgent above)

> Source/WebCore/inspector/InspectorAgent.h:223
> +    OwnPtr<InspectorDOMDebuggerAgent> m_DOMDebuggerAgent;


> Source/WebCore/inspector/InspectorInstrumentation.cpp:147
> +        DOMDebuggerAgent->willModifyDOMAttr(element);

DOMDebuggerAgent -> domDebuggerAgent
Comment 3 Ilya Tikhonovsky 2011-05-05 04:34:16 PDT
Created attachment 92402 [details]
[patch] second version
Comment 4 Ilya Tikhonovsky 2011-05-05 22:27:28 PDT
manually landed as r85850