Bug 60007

Summary: REGRESSION (r83122): CSS !important not respected by JavaScript
Product: WebKit Reporter: Ian Henderson <ian>
Component: CSSAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, mitz, simon.fraser
Priority: P1 Keywords: InRadar, Regression
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
See Also: https://bugs.webkit.org/show_bug.cgi?id=159959
Attachments:
Description Flags
proposed patch none

Description Ian Henderson 2011-05-02 20:38:11 PDT
An element with a !important property in its style will allow you to override this property in JavaScript without using !important.  Caused by <http://trac.webkit.org/changeset/83122>.
Comment 1 Ian Henderson 2011-05-02 20:38:27 PDT
<rdar://problem/9299919>
Comment 2 mitz 2011-05-02 20:46:39 PDT
<rdar://problem/9299919>
Comment 3 Ian Henderson 2011-05-02 20:47:31 PDT
Created attachment 92042 [details]
proposed patch
Comment 4 WebKit Commit Bot 2011-05-02 22:08:02 PDT
Comment on attachment 92042 [details]
proposed patch

Clearing flags on attachment: 92042

Committed r85585: <http://trac.webkit.org/changeset/85585>
Comment 5 WebKit Commit Bot 2011-05-02 22:08:07 PDT
All reviewed patches have been landed.  Closing bug.