Bug 59492

Summary: Port Mozilla's IndexedDB tests: add twice failure
Product: WebKit Reporter: Mark Pilgrim (Google) <pilgrim>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, dgrogan, fishd, hans, pilgrim, tony
Priority: P3    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
patch with changelog and layouttest
tony: review+
rebase webkit directory none

Description Mark Pilgrim (Google) 2011-04-26 14:12:25 PDT
Original test: http://mxr.mozilla.org/mozilla2.0/source/dom/indexedDB/test/test_add_twice_failure.html?force=1

This is a port of a test from Mozilla's IndexedDB test suite. It checks that adding the same key twice to an object store results in a CONSTRAINT_ERR. WebKit passes this test.
Comment 1 Mark Pilgrim (Google) 2011-04-26 14:16:09 PDT
Created attachment 91155 [details]
patch with changelog and layouttest
Comment 2 Mark Pilgrim (Google) 2011-04-26 19:41:56 PDT
Created attachment 91217 [details]
rebase webkit directory
Comment 3 Mark Pilgrim (Google) 2011-04-27 14:40:05 PDT
*** Bug 58560 has been marked as a duplicate of this bug. ***
Comment 4 WebKit Commit Bot 2011-04-27 18:30:17 PDT
The commit-queue encountered the following flaky tests while processing attachment 91217 [details]:

http/tests/appcache/fallback.html bug 52710 (authors: ap@webkit.org and michaeln@google.com)
The commit-queue is continuing to process your patch.
Comment 5 WebKit Commit Bot 2011-04-27 18:31:40 PDT
Comment on attachment 91217 [details]
rebase webkit directory

Clearing flags on attachment: 91217

Committed r85134: <http://trac.webkit.org/changeset/85134>
Comment 6 WebKit Commit Bot 2011-04-27 18:31:45 PDT
All reviewed patches have been landed.  Closing bug.