Bug 58890

Summary: REGRESSION (r84206): 50 tests failing on SnowLeopard Intel Release (WebKit2 Tests) due to extra "supportsFullScreen() == true" output
Product: WebKit Reporter: Adam Roben (:aroben) <aroben>
Component: Tools / TestsAssignee: Jer Noble <jer.noble>
Status: RESOLVED FIXED    
Severity: Normal CC: jer.noble, sam
Priority: P2 Keywords: InRadar, LayoutTestFailure, MakingBotsRed, Regression
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.6   
Attachments:
Description Flags
Patch aroben: review+

Description Adam Roben (:aroben) 2011-04-19 06:27:20 PDT
r84194, 1 failure:
http://build.webkit.org/builders/SnowLeopard%20Intel%20Release%20%28WebKit2%20Tests%29/builds/10828

r84210, 51 failures:
http://build.webkit.org/builders/SnowLeopard%20Intel%20Release%20%28WebKit2%20Tests%29/builds/10829

All the extra failures look like this:

@@ -1,3 +1,4 @@
+supportsFullScreen() == true
 layer at (0,0) size 800x600
   RenderView at (0,0) size 800x600
 layer at (0,0) size 800x50
Comment 1 Adam Roben (:aroben) 2011-04-19 06:46:19 PDT
<rdar://problem/9304546>
Comment 2 Jer Noble 2011-04-19 09:43:28 PDT
The 51 failures which have the extra stdout line in them look like the fault of r84206.  I'll take this.
Comment 3 Jer Noble 2011-04-19 09:53:30 PDT
Created attachment 90211 [details]
Patch
Comment 4 Adam Roben (:aroben) 2011-04-19 09:54:17 PDT
Comment on attachment 90211 [details]
Patch

Not only does it default to false, no one ever sets it to true! Is that really what we want?
Comment 5 Jer Noble 2011-04-19 09:56:52 PDT
Since it's in the .idl, it can be set from within a test script.  I can imagine it being helpful to turn on only for the LayoutTests/fullscreen/ set of tests.
Comment 6 Jer Noble 2011-04-19 10:05:50 PDT
Committed r84262: <http://trac.webkit.org/changeset/84262>