Bug 58349

Summary: Implement (contribute to) CSS3 Grid Layout
Product: WebKit Reporter: Darth <priyajeet.hora@gmail.com>
Component: CSSAssignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED DUPLICATE    
Severity: Enhancement CC: matt11ag-webkitbugs@yahoo.com, mike@w3.org, peter@chromium.org, priyajeet.hora@gmail.com, shanestephens@google.com, techgurufloyd+webkitbugs@gmail.com
Priority: P3    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
URL: http://ie.microsoft.com/testdrive/HTML5/GridSystem/Default.html

Description From 2011-04-12 10:48:13 PST
http://ie.microsoft.com/testdrive/HTML5/GridSystem/Default.html
http://www.interoperabilitybridges.com/css3-grid-align/

Could not find a bug associated with this so opening one.
Would be nice to get some experimental version of it out, irrespective of whether it conforms completely to the microsoft counterpart.
------- Comment #1 From 2011-04-13 17:58:09 PST -------
Please also ensure that absolute-positioned children are supported inside of grid "cells".

I've noticed that IE 10 supports this in both "grid alignment" layouts as well as in "flexbox" layouts.

I bring this up because WebKit does not support absolute-positioned children inside of flexbox boxes as seen in WebKit bug 58453.
------- Comment #2 From 2011-04-13 18:12:07 PST -------
Here's the link to the official W3C draft:
http://dev.w3.org/csswg/css3-grid-align/
------- Comment #3 From 2011-05-09 16:52:03 PST -------
It has graduated from the dev.w3.org server as "Grid Layout":
http://www.w3.org/TR/css3-grid-layout/
------- Comment #4 From 2011-07-19 16:09:21 PST -------
Marking this one as the duplicate, considering bug 60731 already has dependencies.

*** This bug has been marked as a duplicate of bug 60731 ***