Bug 57816

Summary: REGRESSION(r82876): Caused a lot of test crashes (Requested by tkent on #webkit).
Product: WebKit Reporter: WebKit Review Bot <webkit.review.bot>
Component: New BugsAssignee: WebKit Review Bot <webkit.review.bot>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, commit-queue, eric, ggaren, oliver
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 57502    
Attachments:
Description Flags
ROLLOUT of r82876 none

Description WebKit Review Bot 2011-04-04 22:23:06 PDT
http://trac.webkit.org/changeset/82876 broke the build:
Caused a lot of test crashes (Requested by tkent on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2011-04-04 22:23:29 PDT
Created attachment 88184 [details]
ROLLOUT of r82876

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Oliver Hunt 2011-04-04 22:24:49 PDT
What are the crashes?  Given the purpose of this patch was to detect buffer overruns, etc I'd like to know exactly what is causing the crashes.
Comment 3 WebKit Commit Bot 2011-04-04 22:33:56 PDT
Comment on attachment 88184 [details]
ROLLOUT of r82876

Clearing flags on attachment: 88184

Committed r82905: <http://trac.webkit.org/changeset/82905>
Comment 4 WebKit Commit Bot 2011-04-04 22:34:01 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 WebKit Review Bot 2011-04-04 23:58:09 PDT
http://trac.webkit.org/changeset/82905 might have broken GTK Linux 64-bit Debug