Bug 56772

Summary: Dragging text in a WebKit2 window results in a copy instead of a move
Product: WebKit Reporter: Enrica Casucci <enrica>
Component: HTML EditingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: adele, darin
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: OS X 10.5   
Attachments:
Description Flags
Patch darin: review+

Description Enrica Casucci 2011-03-21 15:20:31 PDT
Repro steps:
1. Open a WebKit2 window and navigate to http://www.mozilla.org/editor/midasdemo/
2. Type "hello world".
3. Double click on "world" to select the word and drag it in front of the word "hello".

Expected:

"world hello"

Actual:

"worldhello world"
Comment 1 Enrica Casucci 2011-04-08 10:29:01 PDT
*** Bug 58145 has been marked as a duplicate of this bug. ***
Comment 2 Enrica Casucci 2011-04-08 10:34:04 PDT
Created attachment 88839 [details]
Patch
Comment 3 Enrica Casucci 2011-04-08 10:37:26 PDT
http://trac.webkit.org/changeset/83308
Comment 4 Alexey Proskuryakov 2011-04-09 01:05:29 PDT
<rdar://problem/9165140>