Bug 56695

Summary: Make StructureChain GC allocated
Product: WebKit Reporter: Oliver Hunt <oliver>
Component: New BugsAssignee: Oliver Hunt <oliver>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, buildbot, eric, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Removed export from windows .def file, now need to wait to find out what the new version is called
none
Patch ggaren: review+

Description Oliver Hunt 2011-03-18 16:57:45 PDT
Make StructureChain GC allocated
Comment 1 Oliver Hunt 2011-03-18 16:59:11 PDT
Created attachment 86243 [details]
Patch
Comment 2 WebKit Review Bot 2011-03-18 17:00:47 PDT
Attachment 86243 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptCore/bytecode/Instruction.h:85:  _stubRoutine is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:85:  _base is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:85:  _chain is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/StructureStubInfo.cpp:83:  A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]
Total errors found: 4 in 24 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Oliver Hunt 2011-03-18 17:13:42 PDT
Don't review this patch, i'm just waiting to see how the various bots deal with it
Comment 4 Oliver Hunt 2011-03-20 20:01:19 PDT
Created attachment 86291 [details]
Patch
Comment 5 WebKit Review Bot 2011-03-20 20:03:05 PDT
Attachment 86291 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptCore/bytecode/Instruction.h:85:  _stubRoutine is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:85:  _base is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:85:  _chain is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 3 in 24 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Geoffrey Garen 2011-03-30 13:25:42 PDT
Comment on attachment 86291 [details]
Patch

r=me

On my machine, this is a 0.2% speedup on SunSpider, and no change on v8.
Comment 7 Oliver Hunt 2011-03-30 14:39:33 PDT
Comment on attachment 86291 [details]
Patch

Clearing flags on attachment: 86291

Committed r82500: <http://trac.webkit.org/changeset/82500>
Comment 8 Oliver Hunt 2011-03-30 14:39:37 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 WebKit Review Bot 2011-03-30 15:28:03 PDT
http://trac.webkit.org/changeset/82500 might have broken Leopard Intel Debug (Tests) and Windows 7 Release (Tests)
The following tests are not passing:
fast/dom/Window/window-postmessage-clone.html
fast/workers/shared-worker-frame-lifecycle.html
fast/workers/worker-close-more.html
inspector/debugger/debugger-breakpoints-not-activated-on-reload.html
inspector/debugger/scripts-panel.html
Comment 10 Oliver Hunt 2011-03-30 16:54:27 PDT
Rolled out in r82519 as someone deemed it reasonable to break DRT so i couldn't fix in trunk fast enough
Comment 11 Oliver Hunt 2011-04-01 17:13:24 PDT
Created attachment 87947 [details]
Patch
Comment 12 WebKit Review Bot 2011-04-01 17:15:46 PDT
Attachment 87947 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptCore/bytecode/Instruction.h:86:  _stubRoutine is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:86:  _base is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:86:  _chain is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/JSZombie.cpp:38:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Total errors found: 4 in 33 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 13 Build Bot 2011-04-01 18:08:35 PDT
Attachment 87947 [details] did not build on win:
Build output: http://queues.webkit.org/results/8307303
Comment 14 Oliver Hunt 2011-04-01 18:11:42 PDT
Created attachment 87950 [details]
Removed export from windows .def file, now need to wait to find out what the new version is called
Comment 15 WebKit Review Bot 2011-04-01 18:13:43 PDT
Attachment 87950 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptCore/bytecode/Instruction.h:86:  _stubRoutine is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:86:  _base is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:86:  _chain is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/JSZombie.cpp:38:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Total errors found: 4 in 33 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 16 Build Bot 2011-04-01 19:41:55 PDT
Attachment 87950 [details] did not build on win:
Build output: http://queues.webkit.org/results/8320362
Comment 17 Build Bot 2011-04-01 19:50:39 PDT
Attachment 87950 [details] did not build on win:
Build output: http://queues.webkit.org/results/8185366
Comment 18 Oliver Hunt 2011-04-04 10:09:22 PDT
Created attachment 88073 [details]
Patch
Comment 19 WebKit Review Bot 2011-04-04 10:11:05 PDT
Attachment 88073 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style']" exit_code: 1

Source/JavaScriptCore/bytecode/Instruction.h:86:  _stubRoutine is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:86:  _base is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/bytecode/Instruction.h:86:  _chain is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 3 in 34 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 20 Geoffrey Garen 2011-04-04 10:41:51 PDT
Comment on attachment 88073 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=88073&action=review

Hard to tell just by looking if this is correct, but if the tests pass, it look generally OK.

> Source/JavaScriptCore/runtime/Structure.h:112
> +            if (m_prototype)
> +                markStack.append(&m_prototype);

Just noticed this, although it's not new in your patch:

It would be nice to get rid of the concept of a JSValue() prototype, and use jsNull() instead, to get rid of this branch.
Comment 21 Oliver Hunt 2011-04-04 11:44:15 PDT
Committed r82849: <http://trac.webkit.org/changeset/82849>
Comment 22 WebKit Review Bot 2011-04-04 12:46:08 PDT
http://trac.webkit.org/changeset/82849 might have broken WinCE Release (Build)