Bug 56479

Summary: DocumentThreadableLoaderClient needs a protected default Constructor
Product: WebKit Reporter: Bill Budge <bbudge>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, levin
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 53925    
Attachments:
Description Flags
Proposed Patch none

Description Bill Budge 2011-03-16 12:51:18 PDT
DocumentThreadableLoaderClient can't be used as a base class without a protected constructor.
Comment 1 Bill Budge 2011-03-16 13:00:43 PDT
Created attachment 85958 [details]
Proposed Patch

Need this patch to use DocumentThreadableLoaderClient in AssociatedURLLoader::ClientAdapter.
Comment 2 WebKit Commit Bot 2011-03-16 15:07:11 PDT
Comment on attachment 85958 [details]
Proposed Patch

Clearing flags on attachment: 85958

Committed r81282: <http://trac.webkit.org/changeset/81282>
Comment 3 WebKit Commit Bot 2011-03-16 15:07:15 PDT
All reviewed patches have been landed.  Closing bug.