Bug 5484

Summary: REGRESSION: reproducible crash in CachedCSSStyleSheet::setCharset
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Layout and RenderingAssignee: Dave Hyatt <hyatt>
Status: VERIFIED FIXED    
Severity: Critical    
Priority: P1    
Version: 420+   
Hardware: Mac   
OS: OS X 10.4   
URL: http://www.czechairlines.com
Attachments:
Description Flags
proposed fix darin: review+

Description Alexey Proskuryakov 2005-10-24 13:24:36 PDT
Steps to reproduce: open http://www.czechairlines.com in ToT

Results: complains about memory trashing in the console; occasionally crashes.

Caused by my fix to bug 5140 - ironically, I was running with that patch locally applied for a month, but 
saw this crash only the day it was committed :(
Comment 1 Alexey Proskuryakov 2005-10-24 13:25:09 PDT
Created attachment 4461 [details]
proposed fix
Comment 2 Darin Adler 2005-10-24 13:57:42 PDT
Comment on attachment 4461 [details]
proposed fix

Oops! r=me
Comment 3 Timothy Hatcher 2005-10-24 14:44:52 PDT
I am landing this.
Comment 4 Timothy Hatcher 2005-10-24 14:51:42 PDT
/cvs/root/WebCore/ChangeLog,v  <--  ChangeLog
new revision: 1.274; previous revision: 1.273

Checking in khtml/misc/loader.cpp;
/cvs/root/WebCore/khtml/misc/loader.cpp,v  <--  loader.cpp
new revision: 1.80; previous revision: 1.79