Bug 53159

Summary: V8GCController::checkMemoryUsage() should let the web client to determine high and low memory usage
Product: WebKit Reporter: Xianzhu Wang <phnixwxz>
Component: WebCore JavaScriptAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: wangxianzhu
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   

Description Xianzhu Wang 2011-01-25 20:39:11 PST
V8GCController::checkMemoryUsage() now uses fixed values for Chromium and QT, and call through PlatformBridge for Android.

We should add some methods such as lowMemoryUsageMB() and highMemoryUsageMB() into Chromium PlatformBridge and WebClient so that the web client can determine suitable numbers.
Comment 1 Xianzhu Wang 2012-06-04 10:53:26 PDT

*** This bug has been marked as a duplicate of bug 67575 ***