Bug 53035

Summary: Flaky Test: http/tests/security/cross-origin-css.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: WebKit Commit Bot <commit-queue>
Status: NEW ---    
Severity: Normal CC: abarth, cevans, eric
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 50856    
Attachments:
Description Flags
Archive of layout-test-results from eseidel-cq-sl
none
Archive of layout-test-results from cr-jail-8
none
Archive of layout-test-results from cr-jail-8 none

Description WebKit Commit Bot 2011-01-24 12:10:18 PST
This is an automatically generated bug from the commit-queue.
http/tests/security/cross-origin-css.html has been flaky on the commit-queue.

http/tests/security/cross-origin-css.html was authored by cevans@google.com.
http://trac.webkit.org/browser/trunk/LayoutTests/http/tests/security/cross-origin-css.html

The commit-queue just saw http/tests/security/cross-origin-css.html flake (Test timed out) while processing attachment 79939 [details] on bug 53022.
Bot: eseidel-cq-sl  Port: Mac  Platform: Mac OS X 10.6.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2011-01-24 12:10:22 PST
Created attachment 79953 [details]
Archive of layout-test-results from eseidel-cq-sl
Comment 2 WebKit Commit Bot 2011-02-19 00:57:05 PST
The commit-queue just saw http/tests/security/cross-origin-css.html flake (Test timed out) while processing attachment 83051 [details] on bug 54789.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
Comment 3 WebKit Commit Bot 2011-02-19 00:57:08 PST
Created attachment 83065 [details]
Archive of layout-test-results from cr-jail-8
Comment 4 Eric Seidel (no email) 2011-02-24 15:43:19 PST
Comment on attachment 79953 [details]
Archive of layout-test-results from eseidel-cq-sl

zip uploading was broken for a while.  Fixed now.
Comment 5 Eric Seidel (no email) 2011-02-24 15:59:57 PST
Here it looks like all the loads from the httpd server actually completed:

127.0.0.1 - - [19/Feb/2011:00:44:48 -0800] "GET /security/cross-frame-access-selection.html HTTP/1.1" 200 1847
::1 - - [19/Feb/2011:00:44:48 -0800] "GET /security/resources/foreign-domain-iframe-for-selection-test.html HTTP/1.1" 200 424
127.0.0.1 - - [19/Feb/2011:00:44:48 -0800] "GET /security/cross-origin-css-in-xml.xml HTTP/1.1" 200 773
127.0.0.1 - - [19/Feb/2011:00:44:48 -0800] "GET /security/resources/xorigincss6.html HTTP/1.1" 200 37
127.0.0.1 - - [19/Feb/2011:00:44:48 -0800] "GET /security/cross-origin-css.html HTTP/1.1" 200 2578
127.0.0.1 - login [19/Feb/2011:00:44:48 -0800] "GET /security/resources/redir.php?url=http://localhost:8000/security/resources/xorigincss1.css HTTP/1.1" 302 -
::1 - - [19/Feb/2011:00:44:48 -0800] "GET /security/resources/xorigincss1.css HTTP/1.1" 200 54
127.0.0.1 - - [19/Feb/2011:00:44:48 -0800] "GET /security/resources/xorigincss5.html HTTP/1.1" 200 54
127.0.0.1 - - [19/Feb/2011:00:44:49 -0800] "GET /security/resources/xorigincss3.html HTTP/1.1" 200 54
127.0.0.1 - login [19/Feb/2011:00:44:50 -0800] "GET /security/resources/redir.php?url=http://localhost:8000/security/resources/xorigincss2.html HTTP/1.1" 302 -
127.0.0.1 - login [19/Feb/2011:00:44:50 -0800] "GET /security/resources/redir.php?url=http://localhost:8000/security/resources/xorigincss2.css HTTP/1.1" 302 -
::1 - - [19/Feb/2011:00:44:50 -0800] "GET /security/resources/xorigincss2.html HTTP/1.1" 200 54
127.0.0.1 - login [19/Feb/2011:00:44:51 -0800] "GET /security/resources/redir.php?url=http://localhost:8000/security/resources/xorigincss4.html HTTP/1.1" 302 -
::1 - - [19/Feb/2011:00:44:51 -0800] "GET /security/resources/xorigincss2.css HTTP/1.1" 200 54
::1 - - [19/Feb/2011:00:44:51 -0800] "GET /security/resources/xorigincss4.html HTTP/1.1" 200 37
127.0.0.1 - - [19/Feb/2011:00:44:25 -0800] "GET /multipart/resources/multipart-wait-before-boundary.php HTTP/1.1" 200 6353
127.0.0.1 - - [19/Feb/2011:00:44:47 -0800] "GET /plugins/resources/slow-resource.pl HTTP/1.1" 200 18061
127.0.0.1 - - [19/Feb/2011:00:44:47 -0800] "GET /plugins/resources/slow-resource.pl HTTP/1.1" 200 18061

I don't see the load for "resources/redir.php?url=http://localhost:8000/security/resources/xorigincss1.htm" ever completing in the log.

redir.php looks pretty simple:

<?php
header("location: ".$_GET["url"]);
?>
Comment 6 Eric Seidel (no email) 2011-02-24 16:05:22 PST
I wonder if the preloader could be getting us in trouble here.  If somehow we're deadlocking on a subresource or something.
Comment 7 WebKit Commit Bot 2011-03-04 23:40:56 PST
The commit-queue just saw http/tests/security/cross-origin-css.html flake (Test timed out) while processing attachment 84831 [details] on bug 55796.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
Comment 8 WebKit Commit Bot 2011-03-04 23:41:00 PST
Created attachment 84847 [details]
Archive of layout-test-results from cr-jail-8