Bug 51841

Summary: [Chromium] Add CSS3 elliptical gradient support to GradientSkia
Product: WebKit Reporter: Mihai Parparita <mihai>
Component: Layout and RenderingAssignee: noel gordon <noel.gordon>
Status: RESOLVED FIXED    
Severity: Normal CC: andreip, bsalomon, commit-queue, jamesr, peter, reed, senorblanco
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 55742, 56736    
Attachments:
Description Flags
Patch
none
Patch fix spelling none

Description Mihai Parparita 2011-01-03 11:59:48 PST
The patches in bug 28152 added support for the current CSS3 gradient spec, including elliptical graidents. We'll probably need to do a similar change to:

http://trac.webkit.org/changeset/74915/trunk/WebCore/platform/graphics/cg/GradientCG.cpp
Comment 1 Mihai Parparita 2011-01-03 12:03:19 PST
For now I've added failing expectations for affected tests: http://trac.webkit.org/changeset/74921
Comment 2 Andrei Popescu 2011-01-06 10:13:32 PST
*** Bug 51988 has been marked as a duplicate of this bug. ***
Comment 3 noel gordon 2011-02-10 18:13:08 PST
Created attachment 82084 [details]
Patch
Comment 4 noel gordon 2011-02-17 00:55:56 PST
Created attachment 82764 [details]
Patch fix spelling

Stephen, could you review this please?
Comment 5 Mike Reed 2011-02-17 06:47:42 PST
LGTM
Comment 6 Stephen White 2011-02-17 07:44:45 PST
(In reply to comment #4)
> Created an attachment (id=82764) [details]
> Patch fix spelling
> 
> Stephen, could you review this please?

This looks fine to me.  However, I'm not a WK reviewer.  James, care to give this an r+?
Comment 7 WebKit Commit Bot 2011-02-18 18:16:53 PST
The commit-queue encountered the following flaky tests while processing attachment 82764 [details]:

http/tests/websocket/tests/handshake-fail-by-cross-origin.html bug 54147 (author: abarth@webkit.org)
The commit-queue is continuing to process your patch.
Comment 8 WebKit Commit Bot 2011-02-18 18:19:01 PST
Comment on attachment 82764 [details]
Patch fix spelling

Clearing flags on attachment: 82764

Committed r79063: <http://trac.webkit.org/changeset/79063>
Comment 9 WebKit Commit Bot 2011-02-18 18:19:05 PST
All reviewed patches have been landed.  Closing bug.