Bug 51039

Summary: Flaky Test: fast/history/history-subframe-with-name.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: Alexey Proskuryakov <ap>
Status: RESOLVED FIXED    
Severity: Normal CC: eric, jsbell, mihaip
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 50856    
Attachments:
Description Flags
Failure diff from cr-jail-7
none
Failure diff from cr-jail-8
none
Failure diff from cr-jail-3
none
Failure diff from cr-jail-7
none
Failure diff from cr-jail-7
none
Failure diff from cr-jail-4
none
Failure diff from cr-jail-7
none
proposed fix
none
more of speculative fix beidson: review+

Description WebKit Commit Bot 2010-12-14 09:11:41 PST
This is an automatically generated bug from the commit-queue.
fast/history/history-subframe-with-name.html has been flaky on the commit-queue.

fast/history/history-subframe-with-name.html was authored by mihaip@chromium.org.
http://trac.webkit.org/browser/trunk/LayoutTests/fast/history/history-subframe-with-name.html

The commit-queue just saw fast/history/history-subframe-with-name.html flake while processing attachment 76535 [details] on bug 51037.
Bot: eseidel-cq-sl  Port: Mac  Platform: Mac OS X 10.6.5

The bots will update this with information from each new failure.

If you would like to track this test fix with another bug, please close this bug as a duplicate.
Comment 1 WebKit Commit Bot 2010-12-22 21:00:07 PST
The commit-queue just saw fast/history/history-subframe-with-name.html flake while processing attachment 77288 [details] on bug 51279.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 2 Eric Seidel (no email) 2010-12-23 00:28:40 PST
This is definitely a real flake.  However it may be a timeout or crash since the flaky test reporter failed to upload a failure diff.  (I'm working on making it better report the type of failure.)
Comment 3 Mihai Parparita 2010-12-23 10:45:11 PST
(In reply to comment #2)
> This is definitely a real flake.  However it may be a timeout or crash since the flaky test reporter failed to upload a failure diff.  (I'm working on making it better report the type of failure.)

Timeout seems quite likely (the test is supposed to advance through a bunch of states, it may be getting stuck at one of them).
Comment 4 Mihai Parparita 2010-12-23 11:16:59 PST
I tried to reproduce with:

$ run-webkit-tests fast/history --iterations=100 --exit-after-n-failures=1 --exit-after-n-crashes-or-timeouts=1
$ run-webkit-tests fast/history/history-subframe-with-name.html --iterations=100 --exit-after-n-failures=1 --exit-after-n-crashes-or-timeouts=1

Neither one showed any failures. Any ideas about what's special in the cq environment?
Comment 5 WebKit Commit Bot 2011-02-14 10:50:43 PST
The commit-queue just saw fast/history/history-subframe-with-name.html flake (Text diff mismatch) while processing attachment 82311 [details] on bug 54000.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
Comment 6 WebKit Commit Bot 2011-02-14 10:50:46 PST
Created attachment 82338 [details]
Failure diff from cr-jail-7
Comment 7 WebKit Commit Bot 2011-04-01 18:38:15 PDT
The commit-queue just saw fast/history/history-subframe-with-name.html flake (Text diff mismatch) while processing attachment 87925 [details] on bug 57666.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
Comment 8 WebKit Commit Bot 2011-04-01 18:38:17 PDT
Created attachment 87953 [details]
Failure diff from cr-jail-8
Comment 9 WebKit Commit Bot 2011-04-07 20:41:44 PDT
The commit-queue just saw fast/history/history-subframe-with-name.html flake (Text diff mismatch) while processing attachment 88372 [details] on bug 57922.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
Comment 10 WebKit Commit Bot 2011-04-07 20:41:48 PDT
Created attachment 88761 [details]
Failure diff from cr-jail-3
Comment 11 WebKit Commit Bot 2011-04-22 16:58:24 PDT
The commit-queue just saw fast/history/history-subframe-with-name.html flake (Text diff mismatch) while processing attachment 90752 [details] on bug 59225.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
Comment 12 WebKit Commit Bot 2011-04-22 16:58:26 PDT
Created attachment 90805 [details]
Failure diff from cr-jail-7
Comment 13 WebKit Commit Bot 2011-05-04 14:00:15 PDT
The commit-queue just saw fast/history/history-subframe-with-name.html flake (Text diff mismatch) while processing attachment 92252 [details] on bug 59143.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.7
Comment 14 WebKit Commit Bot 2011-05-04 14:00:18 PDT
Created attachment 92315 [details]
Failure diff from cr-jail-7
Comment 15 WebKit Commit Bot 2011-05-18 20:39:22 PDT
The commit-queue just saw fast/history/history-subframe-with-name.html flake (Text diff mismatch) while processing attachment 94022 [details] on bug 60986.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.7
Comment 16 WebKit Commit Bot 2011-05-18 20:39:24 PDT
Created attachment 94039 [details]
Failure diff from cr-jail-4
Comment 17 WebKit Commit Bot 2011-06-02 12:58:36 PDT
The commit-queue just saw fast/history/history-subframe-with-name.html flake (Text diff mismatch) while processing attachment 95716 [details] on bug 61847.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.7
Comment 18 WebKit Commit Bot 2011-06-02 12:58:39 PDT
Created attachment 95788 [details]
Failure diff from cr-jail-7
Comment 19 Alexey Proskuryakov 2013-09-24 15:04:58 PDT
Created attachment 212508 [details]
proposed fix

This test was still flakily failing on Mac WK1, possibly on other testers too.
Comment 20 Alexey Proskuryakov 2013-09-24 15:09:01 PDT
Committed <http://trac.webkit.org/r156362>.

Will reopen if it still fails.
Comment 21 Alexey Proskuryakov 2013-09-24 15:12:23 PDT
*** Bug 87321 has been marked as a duplicate of this bug. ***
Comment 22 Alexey Proskuryakov 2013-09-25 15:27:28 PDT
It still does.
Comment 23 Alexey Proskuryakov 2013-09-25 15:41:17 PDT
Looks like this fix eliminated timeouts, but we still sometimes get state 5 at the end.
Comment 24 Alexey Proskuryakov 2013-09-25 16:12:01 PDT
Created attachment 212634 [details]
more of speculative fix
Comment 25 Alexey Proskuryakov 2013-09-25 16:17:38 PDT
Committed <http://trac.webkit.org/r156431>.