Bug 50884

Summary: REGRESSION(r73307): MobileMe mail viewing is broken
Product: WebKit Reporter: Alice Liu <alice.barraclough>
Component: JavaScriptCoreAssignee: Michael Saboff <msaboff>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, barraclough, ggaren, msaboff
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
URL: http://www.me.com/mail
Attachments:
Description Flags
Patch to fix backtracking to simple parenthenses oliver: review+

Description Alice Liu 2010-12-11 23:59:56 PST
viewing the contents of mobileme mail messages has broken, beginning with r77307.  I hear that r73866 was supposed to be the fix for the bugs.webkit.org regression caused by r77307, but it hasn't fixed the mobileme mail regression, which presumably was unknown until now.  

steps to repro:
1) login to http://www.me.com/mail
2) view any message

results: most messages will appear to be blank, or appear with just one line of text.  

<rdar://problem/8759479>
Comment 1 Michael Saboff 2010-12-13 13:46:15 PST
Created attachment 76429 [details]
Patch to fix backtracking to simple parenthenses

Simple parens are those with a fixed quantity and don't capture.  There is a special case for these parentheses and that code didn't handle backtracking from nested parentheses.
Comment 2 Michael Saboff 2010-12-13 14:20:20 PST
Committed r73962: <http://trac.webkit.org/changeset/73962>