Bug 50823

Summary: Flaky Test: inspector/timeline-event-dispatch.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: Ilya Tikhonovsky <loislo>
Status: RESOLVED FIXED    
Severity: Normal CC: apavlov, beidson, eric, loislo, pfeldman, tony, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 50856    
Attachments:
Description Flags
[patch] initial version none

Description WebKit Commit Bot 2010-12-10 09:33:16 PST
This is an automatically generated bug from the commit-queue.
inspector/timeline-event-dispatch.html has been flaky on the commit-queue.

inspector/timeline-event-dispatch.html was authored by beidson@apple.com and yurys@chromium.org.
http://trac.webkit.org/browser/trunk/inspector/timeline-event-dispatch.html

The commit-queue just saw inspector/timeline-event-dispatch.html flake while processing attachment 76198 [details] on bug 46895.

The bots will update this with information from each new failure.

If you would like to track this test fix with another bug, please close this bug as a duplicate.
Comment 1 Tony Chang 2010-12-10 12:07:18 PST
If this is on chromium, this is probably bug 50722

*** This bug has been marked as a duplicate of bug 50722 ***
Comment 2 Eric Seidel (no email) 2010-12-10 12:10:46 PST
No, this is on Snow Leopard.  The commit-queue is always Snow Leopard.
Comment 3 Tony Chang 2010-12-10 12:15:18 PST
Ok, then not a dupe, although we see this test timeout a lot on chromium debug builds.
Comment 4 WebKit Commit Bot 2010-12-22 13:41:00 PST
The commit-queue just saw inspector/timeline-event-dispatch.html flake while processing attachment 77158 [details] on bug 51429.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 5 Ilya Tikhonovsky 2010-12-29 10:03:34 PST
Created attachment 77627 [details]
[patch] initial version
Comment 6 Ilya Tikhonovsky 2010-12-29 10:06:46 PST
It was a problem with Chromium DRT. DevToolsAgent object instance was
attached not only to the inspected page but to the DevTools window too.
As result all the inspector files were interpreted as a content of inspected page
and were transfered to the DevTools scripts panel for debugging etc.
Comment 7 Pavel Feldman 2010-12-29 10:40:39 PST
Comment on attachment 77627 [details]
[patch] initial version

View in context: https://bugs.webkit.org/attachment.cgi?id=77627&action=review

> Tools/DumpRenderTree/chromium/TestShell.cpp:568
> +    WebView* view = WebView::create(host, attachDevTools ? m_drtDevToolsAgent.get() : 0);

It is true that WebView for devtools should have 0 as WebDevToolsAgentClient. However, even after your fix, same m_drtDevToolsAgent is being reused for different WebViews (and hence encapsulated WebDevToolsAgent instances). This is not right since it results in same host id being used by different WebViews. Are we using this method to create exactly two WebViews - one for layout test and one for DevTools? If so, your fix is Ok. In either case, I'd rather have the views created explicitly and see no generic createNewWindow call that allows reusing the devtools agent client.
Comment 8 Eric Seidel (no email) 2010-12-29 11:36:48 PST
This report was filed by snow leopard commit bots.  It's fine to do your fix too, but your fix only affects Chromium (which is unrelated to this report).
Comment 9 Ilya Tikhonovsky 2010-12-29 11:45:12 PST
(In reply to comment #8)
> This report was filed by snow leopard commit bots.  It's fine to do your fix too, but your fix only affects Chromium (which is unrelated to this report).

It is not clear for me why this bug got this comment.
----------
The commit-queue just saw inspector/timeline-event-dispatch.html flake while processing attachment 77158 [details] on bug 51429.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
----------

As I understand this is a message from chromium bot on mac.
But chromium inspector's test enabled only for Windows.

Could you please throw an amount of light on this?
Comment 10 Eric Seidel (no email) 2010-12-29 11:51:51 PST
(In reply to comment #9)
> It is not clear for me why this bug got this comment.
> ----------
> The commit-queue just saw inspector/timeline-event-dispatch.html flake while processing attachment 77158 [details] [details] on bug 51429.
> Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
> ----------
> 
> As I understand this is a message from chromium bot on mac.
> But chromium inspector's test enabled only for Windows.

Sorry for any confusion.  What that's saying is:

"cr-jail-3" is the bot name.  We run some of the commit-bots in the Chromium jail (a special section of a google datacenter.

The port is "Mac" which is the Apple Mac port.  I could make it say that more explicitly.  Which is different from Chromium Mac.

The Platform it was built on is 10.6.4, Snow Leopard.
Comment 11 Ilya Tikhonovsky 2010-12-30 01:16:04 PST
Comment on attachment 77627 [details]
[patch] initial version

wrong bug