Bug 50102

Summary: IndexedDB: Rename IDBDatabase.objectStores to objectStoreNames
Product: WebKit Reporter: Hans Wennborg <hans>
Component: New BugsAssignee: Hans Wennborg <hans>
Status: RESOLVED FIXED    
Severity: Normal CC: andreip, jorlow
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch jorlow: review+

Description Hans Wennborg 2010-11-26 02:19:49 PST
IndexedDB: Rename IDBDatabase.objectStores to objectStoreNames
Comment 1 Hans Wennborg 2010-11-26 02:27:43 PST
Created attachment 74909 [details]
Patch
Comment 2 Jeremy Orlow 2010-11-26 02:36:03 PST
Comment on attachment 74909 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=74909&action=review

r=me

> WebCore/storage/IDBDatabaseBackendImpl.cpp:250
> +PassRefPtr<IDBTransactionBackendInterface> IDBDatabaseBackendImpl::transaction(DOMStringList* storeNames, unsigned short mode, unsigned long timeout, ExceptionCode&)

rename this to objectStoreNames

> WebKit/chromium/public/WebIDBDatabase.h:64
>          return WebDOMStringList();

I believe this needs to link back.
Comment 3 Hans Wennborg 2010-11-26 03:04:22 PST
Committed r72754: <http://trac.webkit.org/changeset/72754>