Bug 48882

Summary: Add support for NP_HasMethod and NP_Invoke
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Description Flags
Patch aroben: review+

Description Anders Carlsson 2010-11-02 15:59:02 PDT
Add support for NP_HasMethod and NP_Invoke
Comment 1 Anders Carlsson 2010-11-02 16:02:03 PDT
Created attachment 72757 [details]
Comment 2 WebKit Review Bot 2010-11-02 16:05:55 PDT
Attachment 72757 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/platform/mac-wk2/Skipped', u'WebKit2/ChangeLog', u'WebKit2/Platform/CoreIPC/HandleMessage.h', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.cpp', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.h', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.messages.in', u'WebKit2/Shared/Plugins/NPObjectProxy.cpp', u'WebKit2/Shared/Plugins/NPObjectProxy.h']" exit_code: 1
WebKit2/Shared/Plugins/NPObjectProxy.cpp:195:  NPObjectProxy::NP_HasMethod is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:200:  NPObjectProxy::NP_Invoke is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 2 in 8 files

If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Adam Roben (:aroben) 2010-11-02 16:06:58 PDT
Comment on attachment 72757 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=72757&action=review

> WebKit2/Shared/Plugins/NPObjectMessageReceiver.cpp:82
> +    Vector<NPVariant> arguments;
> +    for (size_t i = 0; i < argumentsData.size(); ++i)
> +        arguments.append(m_npRemoteObjectMap->npVariantDataToNPVariant(argumentsData[i]));

Don't we need to release these NPVariants, too?
Comment 4 Anders Carlsson 2010-11-02 16:31:07 PDT
Committed r71183: <http://trac.webkit.org/changeset/71183>