Bug 48436

Summary: REGRESSION (r70335): Incorrect article layout in Safari Reader
Product: WebKit Reporter: mitz
Component: CSSAssignee: mitz
Status: RESOLVED FIXED    
Severity: Normal Keywords: InRadar
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Disable the cross-origin check in getMatchedCSSRules in versions of Safari lined against versions of WebKit that didn’t have the check darin: review+

Description mitz 2010-10-27 10:20:51 PDT
REGRESSION (r70335): Incorrect article layout in Safari Reader
Comment 1 mitz 2010-10-27 10:26:02 PDT
Created attachment 72054 [details]
Disable the cross-origin check in getMatchedCSSRules in versions of Safari lined against versions of WebKit that didn’t have the check
Comment 2 Darin Adler 2010-10-27 10:58:49 PDT
Comment on attachment 72054 [details]
Disable the cross-origin check in getMatchedCSSRules in versions of Safari lined against versions of WebKit that didn’t have the check

View in context: https://bugs.webkit.org/attachment.cgi?id=72054&action=review

> WebCore/ChangeLog:9
> +        (WebCore::DOMWindow::getMatchedCSSRules): Return rules from all origins if the corss-origin

Typo: corss

> WebCore/page/DOMWindow.cpp:1257
>      Document* doc = m_frame->document();

This local variable doesn’t seem to keep its weight.

> WebCore/page/Settings.h:336
> +        bool disableGetMatchedCSSRulesCrossOriginCheck() const { return m_disableGetMatchedCSSRulesCrossOriginCheck; }

For functions that return booleans, I prefer that we not use verb phrases such as “disable”.

> WebCore/page/Settings.h:425
> +        bool m_disableGetMatchedCSSRulesCrossOriginCheck : 1;

Same thing for data members.
Comment 3 Darin Adler 2010-10-27 11:00:55 PDT
Comment on attachment 72054 [details]
Disable the cross-origin check in getMatchedCSSRules in versions of Safari lined against versions of WebKit that didn’t have the check

View in context: https://bugs.webkit.org/attachment.cgi?id=72054&action=review

>> WebCore/page/DOMWindow.cpp:1257
>>      Document* doc = m_frame->document();
> 
> This local variable doesn’t seem to keep its weight.

Sorry, I meant to say “doesn’t improve readability or clarity and is only used once”.
Comment 4 mitz 2010-10-27 14:39:19 PDT
Fixed in <http://trac.webkit.org/changeset/70714>.
Comment 5 Alexey Proskuryakov 2010-11-10 10:59:49 PST
Marking as resolved per the above.
Comment 6 David Kilzer (:ddkilzer) 2010-12-14 17:57:21 PST
<rdar://problem/8591336>