Bug 48109

Summary: Code under ES5 strict mode crashes browser
Product: WebKit Reporter: kangax <kangax@gmail.com>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: ap@webkit.org, aroben@webkit.org, ggaren@apple.com, oliver@apple.com
Priority: P1 Keywords: NeedsRadar
Version: 528+ (Nightly build)   
Hardware: Macintosh Intel   
OS: Mac OS X 10.6   
URL: http://kangax.github.com/fabric.js/test/demo/

Description From 2010-10-21 20:04:38 PST
I can't quite figure out what exactly causes it, but after making code in http://kangax.github.com/fabric.js/test/demo/ run under ES5 strict, WebKit started crashing. The file in question is http://kangax.github.com/fabric.js/dist/all.js

I'll see if I can isolate the problem later.
------- Comment #1 From 2010-10-22 10:43:59 PST -------
Confirmed with r70259.
------- Comment #2 From 2010-10-22 13:33:38 PST -------
Any chance of working out where it's going wrong (alert debugging to get some idea would be fine even)

Or a tarball of that page so i can do it :D
------- Comment #3 From 2010-10-22 13:50:36 PST -------
I think this happens only when I move a mouse. When I don't, it doesn't crash (waited a couple of minutes and it was still running).

I tried adding shapes by keyboard tabbing to buttons that trigger addition and once added, browser crashed again.

So after all, it could be related to rendering, which is triggered by both — mousemove and shape addition.

Will investigate more.
------- Comment #4 From 2010-10-22 13:56:02 PST -------
By the way, this test page (http://github.com/kangax/fabric.js/blob/gh-pages/test/demo/index.html), as well as the entire project (http://github.com/kangax/fabric.js) is on github, so you can clone repo or just download as archive.
------- Comment #5 From 2011-01-20 16:14:04 PST -------
I can no longer reproduce this with r76045. Could you please verify that this works now?
------- Comment #6 From 2011-01-20 16:26:24 PST -------
The webkit has been freezing for me lately, so I can't test it properly unfortunately :/ 

Tried completely removing it (I'm on Mac OS X), installing fresh nightly build, but still have same problem — opening an app spikes up CPU, impossible to open web inspector, everything freezes (and process is shown as not responding).

Have you guys had similar reports from Mac users? (this started happening about 2-3 months ago, at most)
------- Comment #7 From 2011-01-20 16:30:54 PST -------
No, I haven't seen other reports of WebKit nightlies being generally unusable for so long on any platform. Please consider filing a separate bug about that.

Do you have the most recent Safari installed, by the way, and does it work on its own? Nightlies probably won't work well with any earlier Safari version.
------- Comment #8 From 2011-01-20 16:47:42 PST -------
I have latest Safari (5.0; 6533.16). It works fine. But WebKit.app just doesn't want to function w. web inspector opened. I just tried going to fabric.js demo page (the test page that was crashing before) and it does seem to work. So that's great.

However, after opening web inspector and waiting for a couple of minutes for "(not responding)" to disappear, here's how the panel looks — http://twitpic.com/3rv18d
------- Comment #9 From 2011-01-20 17:17:25 PST -------
> I have latest Safari (5.0; 6533.16)

That's quite old, and it's not surprising for nightlies to have issues with it. Please install the latest Mac OS X update (10.6.6), which includes Safari 5.0.3.

Anyway, I'm not sure how this is related to the original bug. The description doesn't mention ever opening the Inspector, and I probably didn't open it when confirming that r70259 was crashing.
------- Comment #10 From 2011-01-20 18:39:14 PST -------
(In reply to comment #9)
> > I have latest Safari (5.0; 6533.16)
> 
> That's quite old, and it's not surprising for nightlies to have issues with it. Please install the latest Mac OS X update (10.6.6), which includes Safari 5.0.3.
> 
> Anyway, I'm not sure how this is related to the original bug. The description doesn't mention ever opening the Inspector, and I probably didn't open it when confirming that r70259 was crashing.

Oh, this isn't related, no. I'll file a separate bug on the inspector freezing. This one can be closed, as I can't reproduce it either.

It's strange that you say my Safari is old. I do have 10.6.6 installed, always keep Safari up to date, and Software Update doesn't show me any other Safari available. That must be the issue then.
------- Comment #11 From 2011-01-20 20:17:14 PST -------
I'm not sure how that could happen. Could it be that Safari 5.0 starts from a different partition for you? The About window of Safari 5.0.3 says "5.0.3 (6533.19.4)", and Finder's Info window says 5.0.3, too.

Thank you for confirming that the crash no longer occurs!