Bug 47613

Summary: [Qt] QtTestBrowser shows two Url input fields
Product: WebKit Reporter: Yi Shen <max.hong.shen>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: ademar, commit-queue, tonikitoo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: S60 Hardware   
OS: S60 3rd edition   
Attachments:
Description Flags
first try none

Description Yi Shen 2010-10-13 12:44:44 PDT
I saw two Url input fields show on the toolbar of QtTestBrowser. In MainWindow::buildUI(), it deletes the old toolbar instance which is supposed to delete the LocationEdit as well, however, it doesn't. To make a quick fix instead of waiting Qt UI code's change, we can explicitly delete the locationedit by ourself on Symbian.
Comment 1 Yi Shen 2010-10-13 12:47:02 PDT
Created attachment 70648 [details]
first try
Comment 2 Antonio Gomes 2010-10-13 12:51:54 PDT
Does it happens on trunk at all?
Comment 3 Yi Shen 2010-10-13 12:54:58 PDT
I think so, it can be reproduced on Symbian with Qt 4.7
Comment 4 Antonio Gomes 2010-10-13 12:56:42 PDT
(In reply to comment #2)
> Does it happens on trunk at all?

because on trunk we have this:

<<<<<>>>
urlEdit = new LocationEdit(m_toolBar);
<<<<<>>>

so when we delete m_toolBar we should also be deleting the urlEdit. Could you please check if the 2.1 branch has this code?
Comment 5 Yi Shen 2010-10-13 13:01:59 PDT
Yes, 2.1 branch has that code. (Remember we have cheery-picked your patches) 
I think the root cause for this issue is from Qt Core/Gui, but we may want to address it quickly by deleting LocationEdit by ourself.
Comment 6 Antonio Gomes 2010-10-13 13:11:54 PDT
I can not reproduce this problem with trunk with qtwebkit on mac :(

what steps are you using?
Comment 7 Yi Shen 2010-10-13 13:12:52 PDT
It is only can be reproduced on Symbian :)
Comment 8 Antonio Gomes 2010-10-13 13:14:03 PDT
(In reply to comment #7)
> It is only can be reproduced on Symbian :)

oh :) ok
Comment 9 Yi Shen 2010-10-13 13:17:27 PDT
Thanks, Antonio :)
Comment 10 WebKit Commit Bot 2010-10-13 16:58:09 PDT
Comment on attachment 70648 [details]
first try

Clearing flags on attachment: 70648

Committed r69714: <http://trac.webkit.org/changeset/69714>
Comment 11 WebKit Commit Bot 2010-10-13 16:58:14 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Ademar Reis 2010-10-15 12:10:02 PDT
Revision r69714 cherry-picked into qtwebkit-2.1 with commit 995f39c <http://gitorious.org/webkit/qtwebkit/commit/995f39c>
Comment 13 Ademar Reis 2010-10-15 12:12:16 PDT
duh, should've been "block" 39121, not "depends on". :-)

Anyway, already integrated.