Bug 47176

Summary: Spatial Navigation: Issues when iframe does not have visible focusable elements.
Product: WebKit Reporter: Yael <yael>
Component: AccessibilityAssignee: Yael <yael>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ademar, laszlo.gombos, tonikitoo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 46905    

Description Yael 2010-10-05 07:16:01 PDT
2 issues were found when an iframe does not contain any visible focusable elements, but does contain focusable elements that are outside of the view.
1. The iframe scrolls to the first focusable item and the text part of it cannot be scrolled into view.
2. When items under the iframe are focused, and trying to scroll up, the iframe never gets focus.
The first issue does not exist in Opera's implementation of Spatial Navigation. The second issue is a bug in Opera as well, but obviously users would want to be able to scroll into the iframe :-(

Here is an example page for this bug:
main page:
<html>
<body>
<iframe src="frame11.html" width=300 height=50></iframe><br>
<a href="#">This is a element</a><br>
<a href="#">This is a element</a><br>
<a href="#">This is a element</a><br>
<a href="#">This is a element</a><br>
</body>
</html>

iframe:
<html>
<body>
This is filler text 1<br>
This is filler text 2<br>
This is filler text 3<br>
This is filler text 4<br>
This is filler text 5<br>
This is filler text 6<br>
This is filler text 7<br>
This is filler text 8<br>
<a href="#">This is a element</a><br>
<a href="#">This is a element</a><br>
<a href="#">This is a element</a><br>
<a href="#">This is a element</a><br>
</body>
</html>
Comment 1 Antonio Gomes 2010-10-05 07:47:23 PDT
Both issues are known and real.

(2) Is really a web design fault, and I think we should not carry much (see that even Opera fails)

(1) is a _must_ fix, yes.

(In reply to comment #0)
> 2 issues were found when an iframe does not contain any visible focusable elements, but does contain focusable elements that are outside of the view.
> 1. The iframe scrolls to the first focusable item and the text part of it cannot be scrolled into view.
> 2. When items under the iframe are focused, and trying to scroll up, the iframe never gets focus.
> The first issue does not exist in Opera's implementation of Spatial Navigation. The second issue is a bug in Opera as well, but obviously users would want to be able to scroll into the iframe :-(
Comment 2 Antonio Gomes 2010-10-05 07:48:07 PDT
(In reply to comment #1)

... specially because frame flattening fix this :)
Comment 3 Yael 2010-11-11 07:53:47 PST
https://bugs.webkit.org/show_bug.cgi?id=49382

*** This bug has been marked as a duplicate of bug 49382 ***
Comment 4 Yael 2010-11-11 07:57:03 PST
This issue is addressed in the patch in https://bugs.webkit.org/show_bug.cgi?id=49382
Comment 5 Ademar Reis 2010-11-11 09:22:58 PST
RESOLVED/DUPLICATED ==> no need to block bug 39121 anymore.