Bug 46176

Summary: [GTK] Bump minimum requirement for libsoup to 2.30
Product: WebKit Reporter: Xan Lopez <xan.lopez>
Component: WebKitGTKAssignee: Xan Lopez <xan.lopez>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, eric, gustavo, mrobinson, webkit.review.bot, xan.lopez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on: 47889    
Bug Blocks:    
Attachments:
Description Flags
soup230.diff none

Description Xan Lopez 2010-09-21 04:46:51 PDT
2.30 is pretty old by now, no reason to not test all our codepaths always.
Comment 1 Xan Lopez 2010-09-21 04:49:03 PDT
Created attachment 68219 [details]
soup230.diff
Comment 2 WebKit Review Bot 2010-09-21 06:27:00 PDT
Attachment 68219 [details] did not build on gtk:
Build output: http://queues.webkit.org/results/4101011
Comment 3 Martin Robinson 2010-09-21 08:43:00 PDT
Comment on attachment 68219 [details]
soup230.diff

View in context: https://bugs.webkit.org/attachment.cgi?id=68219&action=review

> ChangeLog:9
> +        Bump minimum libsoup to required version to 2.30.0.
> +

I think we should list the features which require this version here.
Comment 4 Martin Robinson 2010-09-21 10:29:30 PDT
Comment on attachment 68219 [details]
soup230.diff

Looks good with the ChangeLog expansion.
Comment 5 Martin Robinson 2010-10-12 17:14:46 PDT
Can't recall the status of this issue. Are we waiting on the bot upgrade?
Comment 6 Eric Seidel (no email) 2010-10-13 12:27:33 PDT
Attachment 68219 [details] was posted by a committer and has review+, assigning to Xan Lopez for commit.
Comment 7 Xan Lopez 2010-10-19 00:51:11 PDT
Comment on attachment 68219 [details]
soup230.diff

Pushed as r70034.
Comment 8 Xan Lopez 2010-10-19 00:51:22 PDT
Closing.
Comment 9 WebKit Review Bot 2010-10-19 01:44:36 PDT
http://trac.webkit.org/changeset/70034 might have broken GTK Linux 64-bit Debug
The following tests are not passing:
http/tests/media/video-cookie.html
http/tests/media/video-referer.html