Bug 45509

Summary: REGRESSION: r61215 broke web views with transparent backgrounds
Product: WebKit Reporter: Simon Fraser (smfr) <simon.fraser>
Component: Layout and RenderingAssignee: Simon Fraser (smfr) <simon.fraser>
Status: RESOLVED FIXED    
Severity: Normal CC: hausmann, jarmo.backlund
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: OS X 10.5   

Description Simon Fraser (smfr) 2010-09-09 18:04:16 PDT
r61215 caused RenderView to paint the viewport background when the
document element's renderer is known to not fill opaquely paint
the entire viewport, i.e. more often than it did before.

This exposed a latent, long-standing bug which was introducted
in r14638 (the RenderCanvas -> RenderView rename), where a call
to view()->isTransparent() was not converted to frameView()->isTransparent(),
yet happened to still compile because of RenderObject::isTransparent().

This resulted in us painting the viewport background, even when
WebView clients explicitly said that they wanted a transparent
WebView.
Comment 1 Simon Fraser (smfr) 2010-09-09 18:08:42 PDT
<rdar://problem/8142166>
Comment 2 Simon Fraser (smfr) 2010-09-09 18:08:51 PDT
http://trac.webkit.org/changeset/67137
Comment 3 Simon Hausmann 2010-09-30 06:52:55 PDT
*** Bug 46458 has been marked as a duplicate of this bug. ***
Comment 4 Simon Hausmann 2010-09-30 06:59:05 PDT
<cherry-pick-for-backport: r67137>
Comment 5 Simon Hausmann 2010-09-30 07:00:41 PDT
Revision r67137 cherry-picked into qtwebkit-2.1 with commit bf85131 <http://gitorious.org/webkit/qtwebkit/commit/bf85131>