Bug 44703

Summary: [Qt] tst_QWebFrame::inputFieldFocus() fails on MeeGo Handset with QtWebKit 2.1
Product: WebKit Reporter: Benjamin Poulain <benjamin>
Component: Tools / TestsAssignee: Benjamin Poulain <benjamin>
Status: RESOLVED FIXED    
Severity: Major CC: ademar, commit-queue
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: Other   
OS: Other   
Bug Depends on:    
Bug Blocks: 44675    
Attachments:
Description Flags
Make the test case more robust none

Description Benjamin Poulain 2010-08-26 11:58:23 PDT
The test report a failure, the input field never get the focus.

FAIL! : tst_QWebFrame::inputFieldFocus() 'view.hasFocus()' returned FALSE. ()
Comment 1 Benjamin Poulain 2010-08-26 12:04:31 PDT
Created attachment 65594 [details]
Make the test case more robust

Once again I cannot reproduce the problem on real hardware but it is failing on the test bot.

This is an attempt to make the test more robust, in the hope they will pass the on the test machine.
Comment 2 WebKit Commit Bot 2010-08-27 11:41:17 PDT
Comment on attachment 65594 [details]
Make the test case more robust

Clearing flags on attachment: 65594

Committed r66241: <http://trac.webkit.org/changeset/66241>
Comment 3 WebKit Commit Bot 2010-08-27 11:41:21 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Ademar Reis 2010-08-27 16:12:30 PDT
Revision r66241 cherry-picked into qtwebkit-2.1 with commit 2997cc1e0ba281661ecbbda6db3796d8a1953813