Summary: | [GTK] Inspector extensions tests fail on GTK+ bots because onSelectionChanged is missing | ||||||
---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | Martin Robinson <mrobinson> | ||||
Component: | WebKitGTK | Assignee: | Nobody <webkit-unassigned> | ||||
Status: | RESOLVED FIXED | ||||||
Severity: | Normal | CC: | caseq, joepeck, loislo, pfeldman | ||||
Priority: | P3 | Keywords: | Gtk | ||||
Version: | 528+ (Nightly build) | ||||||
Hardware: | PC | ||||||
OS: | Linux | ||||||
Attachments: |
|
Description
Martin Robinson
2010-08-20 10:05:47 PDT
Committed r65739: <http://trac.webkit.org/changeset/65739> In this case, it appears that WebKitGTK+ is loading a stale copy of the inspector files for the tests. I should have a patch up shortly. Sorry for the noise! Created attachment 65008 [details]
Fix dependency tracking for inspector copied files
Comment on attachment 65008 [details] Fix dependency tracking for inspector copied files > diff --git WebCore/GNUmakefile.am > # RemoteInspectorFrontend and InspectorBackendDispatcher > -DerivedSources/WebCore/RemoteInspectorFrontend.cpp DerivedSources/WebCore/RemoteInspectorFrontend.h DerivedSources/WebCore/InspectorBackendDispatcher.cpp DerivedSources/WebCore/InspectorBackendDispatcher.h: $(WebCore)/inspector/Inspector.idl $(SCRIPTS_BINDINGS) $(WebCore)/inspector/CodeGeneratorInspector.pm > +DerivedSources/WebCore/RemoteInspectorFrontend.cpp DerivedSources/WebCore/RemoteInspectorFrontend.h DerivedSources/WebCore/InspectorBackendDispatcher.cpp DerivedSources/WebCore/InspectorBackendDispatcher.h DerivedSources/WebCore/InspectorBackendStub.js: $(WebCore)/inspector/Inspector.idl $(SCRIPTS_BINDINGS) $(WebCore)/inspector/CodeGeneratorInspector.pm The comment above this should be updated as well. Maybe just something like: "All Web Inspector Generated Files" > +${GENSOURCES_INSPECTOR}/inspector.html: $(WebCore)/inspector/front-end/*.html \ > + $(WebCore)/inspector/front-end/*.js $(WebCore)/inspector/front-end/*.css \ > ... > mkdir -p ${GENSOURCES_INSPECTOR}/images > cp ${dist_webinspector_DATA} ${GENSOURCES_INSPECTOR} > cp ${dist_webinspectorimages_DATA} ${GENSOURCES_INSPECTOR}/images Separate these two lines, it makes it easier to read. And can you instead change the variable (dist_webinspector_DATA) to include the full paths? I'm surprised the `cp` later on works if that didn't have the proper paths. > > + $(WebCore)/inspector/front-end/*.js $(WebCore)/inspector/front-end/*.css \
These are what I wanted separated into two lines.
Comment on attachment 65008 [details]
Fix dependency tracking for inspector copied files
Although I don't like the duplicated lines, I know you tried
a few different approaches. r=me addressing the comments above.
Committed r65767: <http://trac.webkit.org/changeset/65767> |