Bug 43466

Summary: NRWT: websocket_server startup detection failure
Product: WebKit Reporter: Kent Tamura <tkent>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: eric
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch none

Description Kent Tamura 2010-08-03 22:03:19 PDT
websocket_server startup detection sometimes fails on Chromium Windows and Chromium Mac bots.

http://build.webkit.org/builders/Chromium%20Mac%20Release%20(Tests)/builds/950/steps/layout-test/logs/stdio
http://build.webkit.org/builders/Chromium%20Mac%20Release%20(Tests)/builds/1121/steps/layout-test/logs/stdio

Traceback (most recent call last):
  File "./WebKitTools/Scripts/new-run-webkit-tests", line 38, in <module>
    sys.exit(run_webkit_tests.main())
  File "/Users/cltbld/Desktop/BuildSlaveData/WebKit-BuildSlave2/chromium-mac-release-tests/build/WebKitTools/Scripts/webkitpy/layout_tests/run_webkit_tests.py", line 1677, in main
    return run(port_obj, options, args)
  File "/Users/cltbld/Desktop/BuildSlaveData/WebKit-BuildSlave2/chromium-mac-release-tests/build/WebKitTools/Scripts/webkitpy/layout_tests/run_webkit_tests.py", line 1441, in run
    num_unexpected_results = test_runner.run(result_summary)
  File "/Users/cltbld/Desktop/BuildSlaveData/WebKit-BuildSlave2/chromium-mac-release-tests/build/WebKitTools/Scripts/webkitpy/layout_tests/run_webkit_tests.py", line 754, in run
    self._port.start_websocket_server()
  File "/Users/cltbld/Desktop/BuildSlaveData/WebKit-BuildSlave2/chromium-mac-release-tests/build/WebKitTools/Scripts/webkitpy/layout_tests/port/base.py", line 467, in start_websocket_server
    self._websocket_server.start()
  File "/Users/cltbld/Desktop/BuildSlaveData/WebKit-BuildSlave2/chromium-mac-release-tests/build/WebKitTools/Scripts/webkitpy/layout_tests/port/websocket_server.py", line 219, in start
    (self._server_name, self._port))
webkitpy.layout_tests.port.websocket_server.PyWebSocketNotStarted: Failed to start PyWebSocket server on port 8880.

It seems url_is_live() unexpectedly returns False.
Comment 1 Kent Tamura 2010-08-03 22:06:05 PDT
Created attachment 63414 [details]
Patch
Comment 2 Dimitri Glazkov (Google) 2010-08-04 07:51:22 PDT
Comment on attachment 63414 [details]
Patch

ok.
Comment 3 Kent Tamura 2010-08-04 22:17:31 PDT
Comment on attachment 63414 [details]
Patch

Clearing flags on attachment: 63414

Committed r64708: <http://trac.webkit.org/changeset/64708>
Comment 4 Kent Tamura 2010-08-04 22:17:38 PDT
All reviewed patches have been landed.  Closing bug.