Bug 43155

Summary: Implement NPN_HasMethod
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Status: RESOLVED FIXED    
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch sam: review+

Description Anders Carlsson 2010-07-28 15:44:50 PDT
Implement NPN_HasMethod
Comment 1 Anders Carlsson 2010-07-28 15:47:31 PDT
Created attachment 62889 [details]
Patch
Comment 2 WebKit Review Bot 2010-07-28 15:48:14 PDT
Attachment 62889 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:574:  NPN_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:582:  NPN_HasMethod is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:181:  NPJSObject::NP_HasMethod is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:186:  NPJSObject::NP_Invoke is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:192:  NPJSObject::NP_InvokeDefault is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:208:  NPJSObject::NP_SetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:69:  NP_HasMethod is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:70:  NP_Invoke is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:71:  NP_InvokeDefault is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:72:  NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:73:  NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:74:  NP_SetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 12 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-07-28 16:03:40 PDT
Committed r64240: <http://trac.webkit.org/changeset/64240>
Comment 4 Anders Carlsson 2010-07-28 16:35:03 PDT
Committed r64240: <http://trac.webkit.org/changeset/64240>