Bug 43116

Summary: [IndexedDB] IDBKeyRange should be a runtime-enabled feature.
Product: WebKit Reporter: Andrei Popescu <andreip>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: jorlow
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch jorlow: review+

Description Andrei Popescu 2010-07-28 05:25:47 PDT
[IndexedDB] IDBKeyRange should be a runtime-enabled feature.
Comment 1 Andrei Popescu 2010-07-28 05:30:16 PDT
Created attachment 62815 [details]
Patch
Comment 2 Jeremy Orlow 2010-07-28 05:34:09 PDT
Comment on attachment 62815 [details]
Patch

r=me because this fixes a regression

But I'm not sure I like the idea of us adding a bunch of methods which simply just return whether indexedDB is enabled.  I think I'd rather see EnabledAtRuntime optionally take an argument that tells it what function to call.  So this would be EnabledAtRuntime=indexedDB
Comment 3 Andrei Popescu 2010-07-28 05:37:53 PDT
Committed r64201: <http://trac.webkit.org/changeset/64201>