Bug 43061

Summary: REGRESSION: editing/style/remove-underline-from-stylesheet.html fails on Qt platform after r64083
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: HTML EditingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: adele, darin, enrica, justin.garcia, ojan, ossy, tony
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
adds qt-specific expected result justin.garcia: review+

Description Ryosuke Niwa 2010-07-27 10:54:18 PDT
After http://trac.webkit.org/changeset/64083, editing/style/remove-underline-from-stylesheet.html fails on qt platform because of the difference in the editing delegates.
See http://build.webkit.org/results/Qt%20Linux%20Release/r64140%20%2816180%29/editing/style/remove-underline-from-stylesheet-pretty-diff.html
Comment 1 Ryosuke Niwa 2010-07-27 11:14:06 PDT
Created attachment 62714 [details]
adds qt-specific expected result

Since the change in editing delegates do not change the final selection, adding a platform specific result should suffice for now.

But we should really try to fix whatever is causing this discrepancy on the qt platform.
Comment 2 Justin Garcia 2010-07-27 12:05:24 PDT
Comment on attachment 62714 [details]
adds qt-specific expected result

Can you file a bug to cover investigating the differences you see in the editing delegate messages on QT?  r=me
Comment 3 Ryosuke Niwa 2010-07-27 14:58:30 PDT
Patch landed as http://trac.webkit.org/changeset/64163, and a bug 43082 has been filed to follow up the difference in editing delegates.
Comment 4 Ryosuke Niwa 2010-07-27 15:29:29 PDT
Thanks! for the review, Justin.