Bug 42967

Summary: [IndexedDB] IndexedDatabase should be called IDBFactory.
Product: WebKit Reporter: Andrei Popescu <andreip>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, bulach, dglazkov, eric, jorlow, ossy, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
URL: http://www.w3.org/Bugs/Public/show_bug.cgi?id=9790
Bug Depends on:    
Bug Blocks: 42966, 42969    
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Patch jorlow: review+

Description Andrei Popescu 2010-07-26 05:07:01 PDT
Following from:

http://www.w3.org/Bugs/Public/show_bug.cgi?id=9790

the IndexedDatabase should be called IDBFactory. It should also have a method called "databases" that returns a list of all database names.
Comment 1 Andrei Popescu 2010-07-26 14:36:27 PDT
Created attachment 62606 [details]
Patch
Comment 2 Jeremy Orlow 2010-07-27 04:26:45 PDT
Comment on attachment 62606 [details]
Patch

LayoutTests/storage/indexeddb/idb-factory.html:11
 +  <script src="script-tests/idb-factory.js"></script>
You need to sync.  This is no longer here.

WebCore/storage/IDBFactoryPrivateImpl.cpp:55
 +  PassRefPtr<DOMStringList> IDBFactoryPrivateImpl::databases() const
I really don't think we should mix new functionality with the renaming patches.


We need to discuss the naming of this stuff...
Comment 3 Jeremy Orlow 2010-07-27 04:40:43 PDT
Talked in person.  Andrei is going to split this up and better document the new naming scheme.
Comment 4 Andrei Popescu 2010-07-29 08:10:12 PDT
Created attachment 62947 [details]
Patch
Comment 5 Andrei Popescu 2010-07-29 08:29:43 PDT
Created attachment 62948 [details]
Patch
Comment 6 WebKit Review Bot 2010-07-29 09:11:34 PDT
Attachment 62947 [details] did not build on chromium:
Build output: http://queues.webkit.org/results/3619299
Comment 7 Andrei Popescu 2010-07-29 09:13:27 PDT
Created attachment 62956 [details]
Patch
Comment 8 WebKit Review Bot 2010-07-29 10:11:22 PDT
Attachment 62948 [details] did not build on chromium:
Build output: http://queues.webkit.org/results/3567627
Comment 9 Jeremy Orlow 2010-07-30 03:18:34 PDT
Comment on attachment 62956 [details]
Patch

r=me

please coordinate with me when landing
Comment 10 Andrei Popescu 2010-07-30 03:49:00 PDT
Committed r64344: <http://trac.webkit.org/changeset/64344>
Comment 11 WebKit Review Bot 2010-07-30 04:04:56 PDT
http://trac.webkit.org/changeset/64344 might have broken Qt Windows 32-bit Release
Comment 12 Csaba Osztrogonác 2010-07-30 04:10:55 PDT
(In reply to comment #11)
> http://trac.webkit.org/changeset/64344 might have broken Qt Windows 32-bit Release

Sorry, it was a false positive alarm.