Bug 42526

Summary: More NPRuntime work
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Status: RESOLVED FIXED    
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch sam: review+

Description Anders Carlsson 2010-07-18 15:16:41 PDT
More NPRuntime work
Comment 1 Anders Carlsson 2010-07-18 15:19:09 PDT
Created attachment 61914 [details]
Patch
Comment 2 WebKit Review Bot 2010-07-18 15:21:14 PDT
Attachment 61914 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:313:  NPN_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:336:  NPN_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:75:  NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:76:  NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:174:  NPJSObject::NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:179:  NPJSObject::NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 6 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Sam Weinig 2010-07-18 15:22:39 PDT
Comment on attachment 61914 [details]
Patch

> +    static bool NP_HasProperty(NPObject *npobj, NPIdentifier name);
> +    static bool NP_GetProperty(NPObject *npobj, NPIdentifier name, NPVariant *result);

* on the wrong side.

> +
> +    const char *string = identifierRep->string();

* on the wrong side.

Otherwise, r=me.
Comment 4 Anders Carlsson 2010-07-18 15:27:50 PDT
Committed r63636: <http://trac.webkit.org/changeset/63636>