Bug 42524

Summary: Add NPJSObjectMap class
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Status: RESOLVED FIXED    
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch sam: review+

Description Anders Carlsson 2010-07-18 14:23:33 PDT
Add NPJSObjectMap class
Comment 1 Anders Carlsson 2010-07-18 14:27:30 PDT
Created attachment 61913 [details]
Patch
Comment 2 WebKit Review Bot 2010-07-18 14:33:12 PDT
Attachment 61913 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/NPJSObjectMap.h:26:  #ifndef header guard has wrong style, please use: NPJSObjectMap_h  [build/header_guard] [5]
WebKit2/WebProcess/Plugins/NPJSObjectMap.h:34:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:26:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:66:  NP_Allocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:67:  NP_Deallocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:116:  NPJSObject::NP_Allocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:123:  NPJSObject::NP_Deallocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/PluginView.h:42:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Total errors found: 8 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-07-18 14:35:28 PDT
Committed r63631: <http://trac.webkit.org/changeset/63631>