Bug 42284

Summary: Canvas: Rename operator==(CanvasStyle,CanvasStyle) since it isn't a proper equality check
Product: WebKit Reporter: Andreas Kling <kling>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: kenneth
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Renamed it to isColorAndEqualTo(CanvasStyle) kenneth: review+, kenneth: commit-queue-

Description Andreas Kling 2010-07-14 13:22:10 PDT
It only compares if the CanvasStyle is an RGBA or CMYKA color.
Comment 1 Andreas Kling 2010-07-14 13:25:09 PDT
Created attachment 61557 [details]
Renamed it to isColorAndEqualTo(CanvasStyle)
Comment 2 Kenneth Rohde Christiansen 2010-07-14 17:25:44 PDT
What about the name: isEquivalentColor ?
Comment 3 Andreas Kling 2010-07-16 06:22:07 PDT
(In reply to comment #2)
> What about the name: isEquivalentColor ?

r=you for that name? :)
Comment 4 Kenneth Rohde Christiansen 2010-07-19 06:33:12 PDT
Comment on attachment 61557 [details]
Renamed it to isColorAndEqualTo(CanvasStyle)

yes, r=me with that change.
Comment 5 Andreas Kling 2010-07-19 07:52:56 PDT
Committed r63659: <http://trac.webkit.org/changeset/63659>