Bug 40830

Summary: REGRESSION(r60958) [Qt] qwebpage::inputMethods auto-test fails
Product: WebKit Reporter: Simon Hausmann <hausmann>
Component: New BugsAssignee: Simon Hausmann <hausmann>
Status: CLOSED FIXED    
Severity: Normal CC: raine.makelainen
Priority: P1 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
REGRESSION(r60958) [Qt] qwebpage::inputMethods auto-test fails koivisto: review+

Description Simon Hausmann 2010-06-18 05:19:56 PDT
After r60958 the auto-test fails:

FAIL!  : tst_QWebPage::inputMethods(QWebView) '!(inputMethodHints(view) & Qt::ImhHiddenText)' returned FALSE. ()

This is because when activating an input element that is not a password field, we forget to unset the ImhHiddenText input method hint.
Comment 1 Simon Hausmann 2010-06-18 05:21:23 PDT
Created attachment 59098 [details]
REGRESSION(r60958) [Qt] qwebpage::inputMethods auto-test fails
Comment 2 Simon Hausmann 2010-06-18 05:24:09 PDT
Committed r61395: <http://trac.webkit.org/changeset/61395>
Comment 3 Simon Hausmann 2010-06-18 05:24:39 PDT
Cherry-picked into qtwebkit-4.6 with commit a13977ce2aba31808a046cddc082a84dc316d78b
Comment 4 Simon Hausmann 2010-06-18 05:53:06 PDT
Revision r61395 cherry-picked into qtwebkit-2.0 with commit f2ee51a394c63d9f1e625d893c572db70bb8191a