Bug 40446

Summary: [Qt] Only 10 websites can be loaded consecutively when using QtWebkit 2.0
Product: WebKit Reporter: Alexandra Santos <alexandra.1.santos>
Component: New BugsAssignee: Andreas Kling <kling>
Status: CLOSED FIXED    
Severity: Normal CC: hausmann, jukka.jokiniva
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: S60 Hardware   
OS: S60 3rd edition   
Bug Depends on:    
Bug Blocks: 35784    
Attachments:
Description Flags
QtTestBrowser crash logs (collected while using QtWebkit build 51)
none
[Qt][Symbian] Only 10 websites can be loaded consecutively when using QtWebkit 2.0 laszlo.gombos: review+

Description Alexandra Santos 2010-06-10 14:29:48 PDT
Only 10 live websites can be loaded when using QtWebkit 2.0 on a symbian device.

Steps to reproduce:

1.- Install Qt. 4.6.3, QtWebkit 2.0 and QtTestBrowser on a symbian device.
2.- Launch QtTestBrowser
3.- Start loading several webpages.

Actual Results:

QtTestBrowser crashes after loading only 10 websites.

Expected Results:

QtTestBrowser would not crash after loading on 10 websites.

NOTE: An automated test cases is available at http://iop1.nokia-boston.com/stability_live/Stability_Live_iframe.html or http://iop1.nokia-boston.com/stability_live/Stability_Live_multiplewindows.html
Comment 1 Simon Hausmann 2010-06-15 06:53:10 PDT
Can you provide us with the crash logs?

I strongly suspect that this is a duplicate of bug 40072
Comment 2 Alexandra Santos 2010-06-15 07:51:17 PDT
Created attachment 58777 [details]
QtTestBrowser crash logs (collected while using QtWebkit build 51)
Comment 3 Simon Hausmann 2010-06-16 23:16:32 PDT
I haven't been able yet to decode the crash logs, but I also suspect that these are out of memory crashes. If that is the case, then we should mark this bug as duplicate of 40111
Comment 4 Jukka Jokiniva 2010-06-17 07:26:43 PDT
The java script function running the stability test calls itself recursively. I wonder if this can contribute to the problem.
Comment 5 Simon Hausmann 2010-06-28 01:14:31 PDT
*** Bug 40072 has been marked as a duplicate of this bug. ***
Comment 6 Simon Hausmann 2010-06-30 03:02:34 PDT
Created attachment 60104 [details]
[Qt][Symbian] Only 10 websites can be loaded consecutively when using QtWebkit 2.0
Comment 7 Laszlo Gombos 2010-06-30 04:59:29 PDT
Comment on attachment 60104 [details]
[Qt][Symbian] Only 10 websites can be loaded consecutively when using QtWebkit 2.0

lgtm, r+.
Comment 8 Simon Hausmann 2010-06-30 05:02:21 PDT
Committed r62176: <http://trac.webkit.org/changeset/62176>
Comment 9 Simon Hausmann 2010-06-30 05:04:02 PDT
Revision r62176 cherry-picked into qtwebkit-2.0 with commit bcdcd5f5bfc2f48c2881958b4f4d233efcdad8eb