Bug 38788

Summary: CSS3: We fail 'border radius sum of radii' test
Product: WebKit Reporter: James Robinson <jamesr>
Component: CSSAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, davidbarr, mikelawther, simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
URL: http://samples.msdn.microsoft.com/ietestcenter/css3/bordersbackgrounds/border-radius-sum-of-radii-002.htm
Attachments:
Description Flags
Patch
none
Patch none

Description James Robinson 2010-05-07 18:59:35 PDT
We fail the test case in the given URL.  It looks like we let a background element bleed through somehow.  This bug is probably a dupe but I'm not sure what the underlying issue is.
Comment 1 Simon Fraser (smfr) 2011-04-17 21:28:58 PDT
Maybe the negative value in border radius should cause us to ignore that rule, and we're not?
Comment 2 David Barr 2011-05-18 18:57:25 PDT
There is no explicit mention of non-negativity of border radii in the spec:
http://www.w3.org/TR/css3-background/#the-border-radius
The interpretation held in Gecko and IE of strict non-negativity seems reasonable given the lack of description of how negative radii ought to be rendered.

A quick test of making this change in the parser results in a pass. I'll upload a patch shortly.
There also seems to be a regression on part of this test case since this bug was filed - I'll look into that after resolving the issue at hand.
Comment 3 David Barr 2011-05-18 19:26:05 PDT
Created attachment 94032 [details]
Patch
Comment 4 Simon Fraser (smfr) 2011-05-18 20:25:58 PDT
Comment on attachment 94032 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=94032&action=review

> LayoutTests/fast/css/border-radius-non-negative.html:15
> +  border-radius: 30px -150px 30px 30px;

Would be nice to also test a combination of illegal border-top-left-radius with legal border-top-right-radius (for example).
Comment 5 David Barr 2011-05-18 21:39:26 PDT
Created attachment 94041 [details]
Patch
Comment 6 WebKit Commit Bot 2011-05-19 02:46:06 PDT
Comment on attachment 94041 [details]
Patch

Clearing flags on attachment: 94041

Committed r86830: <http://trac.webkit.org/changeset/86830>
Comment 7 WebKit Commit Bot 2011-05-19 02:46:11 PDT
All reviewed patches have been landed.  Closing bug.