Bug 38314

Summary: [Qt] REGRESSION(r57982): tst_qwebpage::showModalDialog() crashes
Product: WebKit Reporter: Simon Hausmann <hausmann>
Component: WebKit QtAssignee: Simon Hausmann <hausmann>
Status: CLOSED FIXED    
Severity: Blocker CC: max.hong.shen
Priority: P1 Keywords: Qt
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 35784    
Attachments:
Description Flags
Patch vestbo: review+

Description Simon Hausmann 2010-04-29 01:33:32 PDT
r57982 caused the showModalDialog() unit test to regress/crash.

This is caused by not always calling mainFrame() anymore, inside ChromeClientQt::createWindow. When returning from that function WebCore expects that a main frame exists.
Comment 1 Simon Hausmann 2010-04-29 01:35:52 PDT
Created attachment 54684 [details]
Patch
Comment 2 Simon Hausmann 2010-04-29 01:42:20 PDT
Committed r58485: <http://trac.webkit.org/changeset/58485>
Comment 3 Simon Hausmann 2010-04-29 01:44:48 PDT
Revision r58485 cherry-picked into qtwebkit-2.0 with commit 52345b219c57e8986cd399c148d85b7909a1dd6e
Comment 4 Yi Shen 2010-04-29 04:38:58 PDT
Sorry Simon, my patch causes the crash :( I will be careful next time