Bug 37416

Summary: SVG background is not transparent
Product: WebKit Reporter: bioinfornatics
Component: SVGAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: adkdmp, cam, krit, simon.fraser, zimmermann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
svg 1 for try locally
none
svg 2 for try locally
none
svg 3 for try locally
none
svg 4 for try locally
none
svg 5 for try locally
none
svg 6 for try locally
none
svg 7 for try locally
none
svg 8 for try locally
none
html file
none
css file
none
UniverseWars.svg none

Description bioinfornatics 2010-04-11 13:21:56 PDT
Created attachment 53100 [details]
svg 1 for try locally

i have a little problem with svg and <object> background is white!
see: http://pix.toile-libre.org/upload/original/1271014776.png

and attach file for test
Comment 1 bioinfornatics 2010-04-11 13:22:35 PDT
Created attachment 53101 [details]
svg 2 for try locally
Comment 2 bioinfornatics 2010-04-11 13:23:05 PDT
Created attachment 53102 [details]
svg 3 for try locally
Comment 3 bioinfornatics 2010-04-11 13:23:36 PDT
Created attachment 53103 [details]
svg 4 for try locally
Comment 4 bioinfornatics 2010-04-11 13:24:07 PDT
Created attachment 53104 [details]
svg 5 for try locally
Comment 5 bioinfornatics 2010-04-11 13:24:42 PDT
Created attachment 53105 [details]
svg 6 for try locally
Comment 6 bioinfornatics 2010-04-11 13:25:18 PDT
Created attachment 53106 [details]
svg 7 for try locally
Comment 7 bioinfornatics 2010-04-11 13:26:35 PDT
Created attachment 53107 [details]
svg 8 for try locally
Comment 8 bioinfornatics 2010-04-11 13:27:19 PDT
Created attachment 53108 [details]
html file
Comment 9 bioinfornatics 2010-04-11 13:28:00 PDT
Created attachment 53109 [details]
css file
Comment 10 bioinfornatics 2010-04-11 16:14:49 PDT
Created attachment 53116 [details]
UniverseWars.svg
Comment 11 bioinfornatics 2010-04-11 16:15:57 PDT
Another test
if i use css background-image:   url(Images/backgrounds/UniverseWars.svg); tranparency work animation motion work but animation color do'nt work with <object> all work but background is white.
i have attach this svg file for testing
Comment 12 Adk 2010-04-12 02:37:24 PDT
(In reply to comment #11)
> Another test
> if i use css background-image:   url(Images/backgrounds/UniverseWars.svg);
> tranparency work animation motion work but animation color do'nt work with
> <object> all work but background is white.
> i have attach this svg file for testing


Same issue with <embed> also.
Comment 13 Cameron McCormack 2010-07-20 17:51:15 PDT

*** This bug has been marked as a duplicate of bug 10687 ***