Bug 36485

Summary: Percent values in styles and french localisation
Product: WebKit Reporter: Vincent Alquier <vincent.alquier>
Component: WebCore JavaScriptAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
URL: http://code.google.com/p/chromium/issues/detail?id=38621
Attachments:
Description Flags
bug.html: to easily reproduce the bug
none
the bug in epiphany-webkit
none
the bug in Chromium
none
the correct rendering none

Description Vincent Alquier 2010-03-23 03:29:15 PDT
Created attachment 51406 [details]
bug.html: to easily reproduce the bug

Bug found in french localisation of Chrome, Chromium and Epiphany-webkit
Works fine in english version of these browsers
Works fine in Linux Firefox
OS + version: Debian unstable
CPU architecture (32-bit / 64-bit): both
Window manager: Gnome
URLs (if relevant): attached bug.html

What steps will reproduce the problem?
1. open the attached bug.html file in english localized chromium browser : it works 
fine
2. open it with a french localized chromium and you won't get the same 
result


What happens instead?

When manipulating styles in javascript :
Percent values in styles are localized by webkit (14.29% => 14,29%) so 
you can't correctly convert them to float to manipulate them.
Comment 1 Vincent Alquier 2010-03-23 03:30:11 PDT
Created attachment 51407 [details]
the bug in epiphany-webkit
Comment 2 Vincent Alquier 2010-03-23 03:31:19 PDT
Created attachment 51408 [details]
the bug in Chromium
Comment 3 Vincent Alquier 2010-03-23 03:31:49 PDT
Created attachment 51409 [details]
the correct rendering
Comment 4 Vincent Alquier 2010-03-24 05:50:33 PDT

*** This bug has been marked as a duplicate of bug 18994 ***