Bug 36058

Summary: [Qt] LayoutTests/fast/canvas/canvas-text-alignment.html skipped on Qt
Product: WebKit Reporter: Chang Shu <cshu>
Component: Tools / TestsAssignee: QtWebKit Unassigned <webkit-qt-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue
Priority: P3 Keywords: Qt
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Bug Depends on: 36853    
Bug Blocks:    
Attachments:
Description Flags
Patch none

Description Chang Shu 2010-03-12 08:25:15 PST
First, we need to generate expected results for this test.
Second, I tried the test on one of our redhat linux server and it showed a hollow rectangle with no texts in it. On the same machine, the firefox generated the same results. However, on another machine running Ubuntu, it worked fine: texts were showing inside the rectangle. I think the problem is under X11 rendering. Can someone verify this on build bot? Thanks!
Comment 1 Csaba Osztrogon√°c 2010-04-01 11:18:56 PDT
Created attachment 52315 [details]
Patch
Comment 2 Eric Seidel (no email) 2010-04-01 17:18:02 PDT
Comment on attachment 52315 [details]
Patch

LGTM.
Comment 3 Kenneth Rohde Christiansen 2010-04-01 20:36:05 PDT
Comment on attachment 52315 [details]
Patch

Looking at the scrollbar in the test, I see another bug: the arrow button is not at the bottom. I filed a bug about that this week, just to let you know.
Comment 4 WebKit Commit Bot 2010-04-06 04:54:37 PDT
Comment on attachment 52315 [details]
Patch

Clearing flags on attachment: 52315

Committed r57142: <http://trac.webkit.org/changeset/57142>
Comment 5 WebKit Commit Bot 2010-04-06 04:54:41 PDT
All reviewed patches have been landed.  Closing bug.