Bug 35777

Summary: High cpu usage when displaying certain pages
Product: WebKit Reporter: Ran <hephooey_dev>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: benjamin
Priority: P4 Keywords: Performance, Qt
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   

Description Ran 2010-03-04 19:54:16 PST
When I open some webpages like http://popgo.net/bbs, the cpu usage becomes 100% and stays very high until I close the webpage. I have tried with the QtWebkit comes with Qt 4.6.2 and the svn r55564 and got the same behavior.
Comment 1 Benjamin Poulain 2010-03-05 15:13:26 PST
I can reproduce the issue with WebKit trunk.

For some reason, on that page, Flash is taking all the CPU when used in Windowed mode. It is literally flooding the windowing server with events.

I think it is better to report that to Adobe.
Comment 2 Ran 2010-03-05 20:49:14 PST
I have tested the website using Firefox with the same flash plugins and the cpu usage is normal, and when I use webkit to view youtube the cpu usage is similar to the usage with Firefox, so I do not think this bug is solely caused by the flash plugin.
Comment 3 Benjamin Poulain 2010-03-06 06:29:41 PST
I tested Firefox as well and had similar result but still, Flash is the problem here.
It is possible to throttle events in WebKit but that seems more of a hack than a solution.

You can try it with valgrind+callgrind, all the time is spent in Flash and GTK, almost no time is taken by WebKit or Qt.
Comment 4 Benjamin Poulain 2010-04-30 03:12:42 PDT

*** This bug has been marked as a duplicate of bug 24913 ***