Summary: | Add a way for WebView and its dependencies to be selectively included in WebKitStatistics leak tracking | ||||||
---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | Timothy Hatcher <timothy> | ||||
Component: | WebKit Misc. | Assignee: | Timothy Hatcher <timothy> | ||||
Status: | RESOLVED FIXED | ||||||
Severity: | Normal | CC: | aroben, darin, mitz | ||||
Priority: | P2 | Keywords: | InRadar | ||||
Version: | 528+ (Nightly build) | ||||||
Hardware: | PC | ||||||
OS: | OS X 10.5 | ||||||
Attachments: |
|
Description
Timothy Hatcher
2010-02-17 10:59:35 PST
Created attachment 48914 [details]
Proposed Change
Comment on attachment 48914 [details]
Proposed Change
This patch will make all WebViews not be included in WebKitStatistics by default. Is that really what we want? This will affect the behavior of all WebKit apps that use WebKitStatistics.
Maybe it would be better to have a way to exclude certain WebViews, rather than excluding them all by default?
WebKitStatistics is private, only Safari uses it. Comment on attachment 48914 [details] Proposed Change > ++ (BOOL)isIncludedInWebKitStatistics; I think it would be better to name this +shouldIncludeInWebKitStatistics. But I'd only change this one method; everything else should keep using "is" (since the other methods/members really mean "have I added myself to the relevant WebKit statistic?"). Should it start with an underscore? r=me (In reply to comment #5) > (From update of attachment 48914 [details]) > > ++ (BOOL)isIncludedInWebKitStatistics; > > I think it would be better to name this +shouldIncludeInWebKitStatistics. For boolean methods we normally make them fit a sentence, like this: "class <xxx>" Using the word "class" since this is a class method. The sentence, "Class should include in WebKit statistics" isn't quite right, so maybe a name like shouldBeIncludedInWebKitStatistics would be more appropriate. |