Bug 35041

Summary: REGRESSION: websocket/tests/frame-lengths.html / websocket/tests/simple-stress.html fail on Windows bot
Product: WebKit Reporter: Nikolas Zimmermann <zimmermann>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap, eric, ukai
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Windows XP   
Bug Depends on: 36380    
Bug Blocks:    

Description Nikolas Zimmermann 2010-02-17 07:40:46 PST
websocket/tests/simple-stress.html
websocket/tests/frame-lengths.html

both fail on windows bots. A lot of those websocket tests have problems across all platforms.
Who is reponsible to look into? :-)
Comment 1 Alexey Proskuryakov 2010-02-17 14:03:26 PST
Do the tests just time out?
Comment 2 Eric Seidel (no email) 2010-02-22 16:48:37 PST
websocket/tests/frame-lengths.html is failing on Tiger too:
http://build.webkit.org/results/Tiger%20Intel%20Release/r55101%20(9004)/websocket/tests/frame-lengths-diffs.txt
--- /Volumes/Data/WebKit-BuildSlave/tiger-intel-release/build/layout-test-results/websocket/tests/frame-lengths-expected.txt	2010-02-22 13:20:53.000000000 -0800
+++ /Volumes/Data/WebKit-BuildSlave/tiger-intel-release/build/layout-test-results/websocket/tests/frame-lengths-actual.txt	2010-02-22 13:20:53.000000000 -0800
@@ -1,7 +1,7 @@
+FAIL: Timed out waiting for notifyDone to be called
 Test sending and receiving small messages of different lengths.
 
 Should say PASS:
 
 Running the test...
-PASS
Comment 3 Eric Seidel (no email) 2010-03-19 12:03:48 PDT
I should file a separate bug for Tiger.  But this perma-failure renders the bot useless.
Comment 4 Alexey Proskuryakov 2010-03-19 13:20:48 PDT
I'm going to address this by increasing DRT timeout.

*** This bug has been marked as a duplicate of bug 36380 ***